aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 10:58:28 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:22 +0100
commit0dc699477e79bb7a9cc1147439dbc04f3d006520 (patch)
tree7a130d008e95ac739f8881b604aa79af52621400 /gnu
parent6446f0dfc3c4c37c72781f079ae415378f668d52 (diff)
downloadguix-0dc699477e79bb7a9cc1147439dbc04f3d006520.tar
guix-0dc699477e79bb7a9cc1147439dbc04f3d006520.tar.gz
gnu: Remove ocaml4.07-bisect-ppx.
* gnu/packages/ocaml.scm (ocaml4.07-bisect-ppx): Remove variable. (ocaml-bisect-ppx)[properties]: Remove variant. Change-Id: I91dcdd486980885530ea2e269328ecf781aee020
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 136ab4151a..1dda348ade 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8446,8 +8446,7 @@ combinators.")
(arguments
;; Tests require ocamlformat which would lead to circular dependencies
'(#:tests? #f))
- (properties `((upstream-name . "bisect_ppx")
- (ocaml4.07-variant . ,(delay ocaml4.07-bisect-ppx))))
+ (properties `((upstream-name . "bisect_ppx")))
(home-page "https://github.com/aantron/bisect_ppx")
(synopsis "Code coverage for OCaml")
(description "Bisect_ppx helps you test thoroughly. It is a small
@@ -8459,32 +8458,6 @@ Usage is simple - add package bisect_ppx when building tests, run your tests,
then run the Bisect_ppx report tool on the generated visitation files.")
(license license:mpl2.0)))
-(define-public ocaml4.07-bisect-ppx
- (package-with-ocaml4.07
- (package
- (inherit ocaml-bisect-ppx)
- (version "2.4.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/aantron/bisect_ppx")
- (commit version)))
- (file-name (git-file-name "ocaml-bisect-ppx" version))
- (sha256
- (base32
- "1njs8xc108rrpx5am5zhhcn6vjva7rsphm8034qp5lgyvnhfgh7q"))))
- (propagated-inputs
- `(("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
- ("ocaml-ppx-tools-versioned" ,ocaml4.07-ppx-tools-versioned)
- ,@(package-propagated-inputs ocaml-bisect-ppx)))
- (native-inputs
- `(("ocaml-ounit2" ,ocaml-ounit2)))
- (arguments
- `(;; tests require git and network
- #:tests? #f))
- (properties '((upstream-name . "bisect_ppx"))))))
-
(define-public ocaml-odoc
(package
(name "ocaml-odoc")