aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-06-24 23:17:12 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-24 23:28:24 +0200
commit0c3f8cb8e8e095003e185ceb0ee10bd2327a5089 (patch)
tree0a348da72ee92edc61aa0a261047f537efe76182 /gnu
parent55b7bbd87f9a5be0f289a9b7b2c5fc193bfc38da (diff)
downloadguix-0c3f8cb8e8e095003e185ceb0ee10bd2327a5089.tar
guix-0c3f8cb8e8e095003e185ceb0ee10bd2327a5089.tar.gz
gnu: Add eog-plugins.
* gnu/packages/gnome.scm (eog-plugins): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a621b4ba54..3f82c184e1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3650,6 +3650,51 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
supports image conversion, rotation, and slideshows.")
(license license:gpl2+)))
+(define-public eog-plugins
+ ;; Note: EOG looks for its plugins (via libpeas) in ~/.local as well as
+ ;; $DATA/lib/eog/plugins, where DATA is one of the entries in
+ ;; $XDG_DATA_DIRS. Thus, for EOG to find these, you have to have
+ ;; 'XDG_DATA_DIRS' appropriately set.
+ (package
+ (name "eog-plugins")
+ (version "3.25.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0an04z8v83qa6j950rbwdzf1s86y7zd8h1r4p2x36fwbkk1m617q"))))
+ (build-system gnu-build-system)
+ (home-page "https://wiki.gnome.org/Apps/EyeOfGnome/Plugins")
+ (synopsis "Extensions for the Eye of GNOME image viewer")
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("gettext" ,gnu-gettext)))
+ (inputs
+ `(("eog" ,eog)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("libpeas" ,libpeas)
+ ("libexif" ,libexif)
+ ("libchamplain" ,libchamplain)))
+ (description
+ "This package provides plugins for the Eye of GNOME (EOG) image viewer,
+notably:
+
+@itemize
+@item @dfn{EXIF Display}, which displays camera (EXIF) information;
+@item @dfn{Map}, which displays a map of where the picture was taken on the
+side panel;
+@item @dfn{Slideshow Shuffle}, to shuffle images in slideshow mode.
+@end itemize\n")
+
+ ;; XXX: eog-postasa-plugin-resources.c (which we don't build) contains a
+ ;; long suspicious byte stream that goes to a
+ ;; ".gresource.eog_postasa_plugin" ELF section.
+ (license license:gpl2+)))
+
(define-public libgudev
(package
(name "libgudev")