aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-05-11 17:05:02 -0700
committerChristopher Baines <mail@cbaines.net>2024-05-13 09:11:06 +0100
commit0b3f2f28c62ded05cacc6e278e5f7cf8a7d4ee1a (patch)
tree28c8c80550dae559a9a973e51901f83fa8cc70a2 /gnu
parentcc212af83ef31d15474e26b39425a0261ff43647 (diff)
downloadguix-0b3f2f28c62ded05cacc6e278e5f7cf8a7d4ee1a.tar
guix-0b3f2f28c62ded05cacc6e278e5f7cf8a7d4ee1a.tar.gz
gnu: llama-cpp: Update to 0.0.0-2.fed0108.
As last update was in February and new changes for new models and memory leaks fixes since then. * gnu/packages/machine-learning.scm (llama-cpp): Update to 0.0.0-2.fed0108. [arguments]<#:phases>: Add 'disable-unrunable-tests' phase. Change replacement of 'install to be a post-install 'install-main' phase so libraries and header files are normally installed. Change-Id: Ia6532945f588747c4d58fdb7611d6a9c3c596705 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 253e2ddef2..a385ddc18c 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -524,8 +524,8 @@ Performance is achieved by using the LLVM JIT compiler.")
(deprecated-package "guile-aiscm-next" guile-aiscm))
(define-public llama-cpp
- (let ((commit "03bf161eb6dea6400ee49c6dc6b69bdcfa9fd3fc")
- (revision "1"))
+ (let ((commit "fed0108491a3a3cbec6c6480dc8667ffff9d7659")
+ (revision "2"))
(package
(name "llama-cpp")
(version (git-version "0.0.0" revision commit))
@@ -537,7 +537,7 @@ Performance is achieved by using the LLVM JIT compiler.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1ag1jash84hasz10h0piw72a8ginm8kzvhihbzzljz96gq2kjm88"))))
+ (base32 "16rm9gy0chd6k07crm8rkl2j3hg7y7h0km7k6c8q7bmm2jrd64la"))))
(build-system cmake-build-system)
(arguments
(list
@@ -559,6 +559,14 @@ Performance is achieved by using the LLVM JIT compiler.")
(guix build python-build-system))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-unrunable-tests
+ ;; test-eval-callback downloads ML model from network, cannot
+ ;; run in Guix build environment
+ (lambda _
+ (substitute* '("examples/eval-callback/CMakeLists.txt")
+ (("add_test") "#add_test"))
+ (substitute* '("examples/eval-callback/CMakeLists.txt")
+ (("set_property") "#set_property"))))
(add-before 'install 'install-python-scripts
(lambda _
(let ((bin (string-append #$output "/bin/")))
@@ -581,7 +589,7 @@ Performance is achieved by using the LLVM JIT compiler.")
(make-script "convert"))))
(add-after 'install-python-scripts 'wrap-python-scripts
(assoc-ref python:%standard-phases 'wrap))
- (replace 'install
+ (add-after 'install 'install-main
(lambda _
(copy-file "bin/main" (string-append #$output "/bin/llama")))))))
(inputs (list python))