aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-06-02 15:24:59 -0500
committerLudovic Courtès <ludo@gnu.org>2020-06-12 18:56:10 +0200
commit0aee6e51b4156430036822ed8dca2f7a84df2258 (patch)
treea10a75125f4310e27e4546768fd5a41186e7ce89 /gnu
parent70a49ef76b3a72176b75c5d4d63e5324d3f9f767 (diff)
downloadguix-0aee6e51b4156430036822ed8dca2f7a84df2258.tar
guix-0aee6e51b4156430036822ed8dca2f7a84df2258.tar.gz
gnu: Add libfastjson.
* gnu/packages/c.scm (libfastjson): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/c.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 12a9b56c51..2e62111d44 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -373,3 +373,30 @@ releases.")
"This C library contains some essential string manipulation functions and
more, like escaping special characters.")
(license license:lgpl2.1+)))
+
+(define-public libfastjson
+ (package
+ (name "libfastjson")
+ (version "0.99.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rsyslog/libfastjson.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qhs0g9slj3p0v2z4s3cnsx44msrlb4k78ljg7714qiziqbrbwyl"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://github.com/rsyslog/libfastjson")
+ (synopsis "Fast JSON library for C")
+ (description
+ "libfastjson is a fork from json-c aiming to provide: a small library
+with essential JSON handling functions, sufficiently good JSON support (not
+100% standards compliant), and very fast processing.")
+ (license license:expat)))