aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-21 23:53:02 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:34 +0200
commit087515d1a781fe1bff584447beeea1be7ae16405 (patch)
tree2669bdf1dbdb8f7e973c8ae299c34718ae3e0f70 /gnu
parent20c46a77afbf79b03175a8a45c5904d26778f525 (diff)
downloadguix-087515d1a781fe1bff584447beeea1be7ae16405.tar
guix-087515d1a781fe1bff584447beeea1be7ae16405.tar.gz
gnu: texlive-newverbs: Do not create origin for "ydocstrip.tex".
* gnu/packages/tex.scm (texlive-newverbs)[native-inputs]: Remove <origin> pointing to "ydocstrip.tex". Grab it from TEXLIVE-YDOC's source instead. Change-Id: I730a34e0e8aaca8a50262d16c05ad4161f068fa0
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 823c42b263..703a214783 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -64560,23 +64560,12 @@ Unicode option of @code{inputenc} or @code{inputenx}, or by XeLaTeX/LuaLaTeX.")
;; a propagated input). To work around this, install the specific
;; "ydocstrip.tex" file from `ydoc' in the build directory and set
;; TEXINPUTS variable accordingly so the process can find it.
- (lambda* (#:key inputs #:allow-other-keys)
- (install-file (search-input-file inputs
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (install-file (search-input-file (or native-inputs inputs)
"tex/generic/ydoc/ydocstrip.tex")
"build/")
(setenv "TEXINPUTS" (string-append (getcwd) "/build:")))))))
- (native-inputs
- (list
- (origin
- (method svn-multi-fetch)
- (uri (svn-multi-reference
- (url (texlive-packages-repository version))
- (revision 66594)
- (locations (list "tex/generic/ydoc/ydocstrip.tex"))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1nixgvmw8c6jznhxys3yfzr3qw1lci8kyx54rs0shm6i63xjgr9i")))))
+ (native-inputs (list (package-source texlive-ydoc)))
(home-page "https://ctan.org/pkg/newverbs")
(synopsis "Define new versions of @code{\\verb}")
(description