aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 21:30:37 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 23:28:18 -0500
commit073cd6092c4feee79c03d38be50d31bfa9cc689c (patch)
tree92ece36dca336edff1c90c204d8e512c7138c0a5 /gnu
parentc0e40804b2a987280e26dc61e0c66b8c6abe30c4 (diff)
downloadguix-073cd6092c4feee79c03d38be50d31bfa9cc689c.tar
guix-073cd6092c4feee79c03d38be50d31bfa9cc689c.tar.gz
gnu: xorg-server: Update to 1.16.2.901, with many security fixes.
Includes fixes for CVE-2014-8091, CVE-2014-8092, CVE-2014-8093, CVE-2014-8094, CVE-2014-8095, CVE-2014-8096, CVE-2014-8097, CVE-2014-8098, CVE-2014-8099, CVE-2014-8100, CVE-2014-8101, CVE-2014-8102, and CVE-2014-8103. See <http://www.x.org/wiki/Development/Security/Advisory-2014-12-09/> * gnu/packages/xorg.scm (xorg-server): Update to 1.16.2.901. Move mesa, resourceproto, scrnsaverproto, and xf86driproto from inputs to propagated-inputs. Add dri3proto and presentproto to propagated-inputs. Add eudev and libxshmfence to inputs. Add a 'pre-configure' phase instead of modifying the 'configure' phase. Adapt substitution that avoids trying to 'mkdir /var' to build system changes. * gnu/services/xorg.scm (xserver.conf): Add xf86-input-evdev ModulePath line.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm50
-rw-r--r--gnu/services/xorg.scm1
2 files changed, 26 insertions, 25 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 94910dcfd2..4a4c01c46d 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4403,35 +4403,41 @@ kernel mode setting (KMS).")
(define-public xorg-server
(package
(name "xorg-server")
- (version "1.12.2")
+ (version "1.16.2.901")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://xorg/X11R7.7/src/everything/xorg-server-"
- version
- ".tar.bz2"))
+ "mirror://xorg/individual/xserver/"
+ name "-" version ".tar.bz2"))
(sha256
- (base32
- "1xf57hcq6r17zxyfnx9r1wd0ir1bw13ff8bsiszwrw9jyhi9x7ya"))))
+ (base32
+ "19jb8v26wc332ramwjdg5vjh3s36kr7n46s6fdfaxrj1wif5m27g"))))
(build-system gnu-build-system)
(propagated-inputs
`(("dri2proto" ,dri2proto)
+ ("dri3proto" ,dri3proto)
("fontsproto" ,fontsproto)
("inputproto" ,inputproto)
("kbproto" ,kbproto)
("libpciaccess" ,libpciaccess)
+ ("mesa" ,mesa)
("pixman" ,pixman)
+ ("presentproto" ,presentproto)
("randrproto" ,randrproto)
("renderproto" ,renderproto)
+ ("resourceproto" ,resourceproto)
+ ("scrnsaverproto" ,scrnsaverproto)
("videoproto" ,videoproto)
("xextproto" ,xextproto)
("xineramaproto" ,xineramaproto)
+ ("xf86driproto" ,xf86driproto)
("xproto" ,xproto)))
(inputs
`(("bigreqsproto" ,bigreqsproto)
("compositeproto" ,compositeproto)
("damageproto" ,damageproto)
+ ("udev" ,eudev)
("dbus" ,dbus)
("dmxproto" ,dmxproto)
("libdmx" ,libdmx)
@@ -4444,16 +4450,13 @@ kernel mode setting (KMS).")
("libxkbfile" ,libxkbfile)
("libxrender" ,libxrender)
("libxres" ,libxres)
+ ("libxshmfence" ,libxshmfence)
("libxt" ,libxt)
("libxv" ,libxv)
- ("mesa" ,mesa)
("recordproto" ,recordproto)
- ("resourceproto" ,resourceproto)
- ("scrnsaverproto" ,scrnsaverproto)
("xcmiscproto" ,xcmiscproto)
("xf86bigfontproto" ,xf86bigfontproto)
("xf86dgaproto" ,xf86dgaproto)
- ("xf86driproto" ,xf86driproto)
("xf86vidmodeproto" ,xf86vidmodeproto)
("xkbcomp" ,xkbcomp)
("xkeyboard-config" ,xkeyboard-config)
@@ -4476,21 +4479,18 @@ kernel mode setting (KMS).")
;; For the log file, etc.
"--localstatedir=/var")
- #:phases
- (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys #:rest args)
- (let ((configure (assoc-ref %standard-phases 'configure)))
- (substitute* (find-files "." "\\.c$")
- (("/bin/sh") (which "sh")))
-
- ;; Don't try to 'mkdir /var'.
- (substitute* "hw/xfree86/Makefile.in"
- (("mkdir(.*)logdir.*")
- "true\n"))
-
- (apply configure args)))
- %standard-phases)))
+
+ #:phases (alist-cons-before
+ 'configure 'pre-configure
+ (lambda _
+ (substitute* (find-files "." "\\.c$")
+ (("/bin/sh") (which "sh")))
+
+ ;; Don't try to 'mkdir /var'.
+ (substitute* "hw/xfree86/Makefile.in"
+ (("\\$\\(MKDIR_P\\).*logdir.*")
+ "true\n")))
+ %standard-phases)))
(home-page "http://www.x.org/wiki/")
(synopsis "Xorg implementation of the X Window System")
(description "X.org provides an implementation of the X Window System")
diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
index d11def6333..b32bb8674c 100644
--- a/gnu/services/xorg.scm
+++ b/gnu/services/xorg.scm
@@ -96,6 +96,7 @@ Section \"Files\"
ModulePath \"" xf86-video-mach64 "/lib/xorg/modules/drivers\"
ModulePath \"" xf86-video-nv "/lib/xorg/modules/drivers\"
ModulePath \"" xf86-video-sis "/lib/xorg/modules/drivers\"
+ ModulePath \"" xf86-input-evdev "/lib/xorg/modules/input\"
ModulePath \"" xf86-input-keyboard "/lib/xorg/modules/input\"
ModulePath \"" xf86-input-mouse "/lib/xorg/modules/input\"
ModulePath \"" xf86-input-synaptics "/lib/xorg/modules/input\"