aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-04 10:04:10 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-04 10:04:10 +0100
commit0214076086e1e2dc96823ddd4fbf1e3068b4d02d (patch)
tree10f40c9d91c57ff4e03ea9410842585d02f402fa /gnu
parent5b841a42fbf3ffd929ba76e37753ba1cb4797125 (diff)
downloadguix-0214076086e1e2dc96823ddd4fbf1e3068b4d02d.tar
guix-0214076086e1e2dc96823ddd4fbf1e3068b4d02d.tar.gz
gnu: go-github-com-elliotchance-orderedmap: Remove submodule.
* gnu/packages/golang-xyz.scm (go-github-com-elliotchance-orderedmap) [arguments]<#:phases>: Add 'remove-submodule phase to reduce amount of data copied to the store, the submodule "v2" is packed separately as it has it's own go.mod file. (go-github-com-elliotchance-orderedmap-v2)[arguments]<#:phases>: Delete 'remove-submodule phase. Change-Id: Ie68ca24752a612864a4c6ca8537949a922528d82
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ee3b410b6d..291f3b9063 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2159,6 +2159,10 @@ program's running, don't expect consistent results between platforms
#:unpack-path "github.com/elliotchance/orderedmap"
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-submodule
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (delete-file-recursively "v2"))))
(replace 'check
(lambda* (#:key tests? import-path #:allow-other-keys)
(when tests?
@@ -2192,7 +2196,10 @@ O(1) for @code{Set}, @code{Get}, @code{Delete} and @code{Len}.")
(arguments
(substitute-keyword-arguments
(package-arguments go-github-com-elliotchance-orderedmap)
- ((#:import-path _) "github.com/elliotchance/orderedmap/v2")))))
+ ((#:import-path _) "github.com/elliotchance/orderedmap/v2")
+ ((#:phases _ '%standard-phases)
+ #~(modify-phases %standard-phases
+ (delete 'remove-submodule)))))))
(define-public go-github-com-emersion-go-ical
(package