aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-05-28 16:36:31 -0700
committerLudovic Courtès <ludo@gnu.org>2023-08-15 23:30:44 +0200
commitb8ee6b8a59bf02f47a6668e016905308b441523e (patch)
tree60b036586ace321aa5754fab0dd2d67a0b5bbbe8 /gnu/tests
parent48d06aee7b39c8e72644d665bd1995cb1ae1b094 (diff)
downloadguix-b8ee6b8a59bf02f47a6668e016905308b441523e.tar
guix-b8ee6b8a59bf02f47a6668e016905308b441523e.tar.gz
services: Add cachefilesd service.
Thanks to Bruno Victal "mirai" for cooperating on this patch and for generously sharing a wealth of insights about Guix services. Thanks to Jean-Baptiste Note for an early version of this service! * doc/guix.texi (Linux Services)[Cachefilesd Service]: New heading. * gnu/services/linux.scm (serialize-string, non-negative-integer?) (serialize-non-negative-integer, string, non-negative-integer) (make-option-serializer, make-percentage-threshold-serializer): New procedures. (cachefilesd-configuration): New record type. (cachefilesd-service-type): New variable. * gnu/tests/cachefilesd.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Co-authored-by: Bruno Victal <mirai@makinata.eu> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/tests')
-rw-r--r--gnu/tests/cachefilesd.scm71
1 files changed, 71 insertions, 0 deletions
diff --git a/gnu/tests/cachefilesd.scm b/gnu/tests/cachefilesd.scm
new file mode 100644
index 0000000000..7f5d513067
--- /dev/null
+++ b/gnu/tests/cachefilesd.scm
@@ -0,0 +1,71 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
+;;; Copyright © 2022 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu tests cachefilesd)
+ #:use-module (gnu tests)
+ #:use-module (gnu system)
+ #:use-module (gnu system vm)
+ #:use-module (gnu services)
+ #:use-module (gnu services linux)
+ #:use-module (guix gexp)
+ #:export (%test-cachefilesd))
+
+(define %cachefilesd-os
+ (simple-operating-system
+ (service cachefilesd-service-type
+ (cachefilesd-configuration
+ (cache-directory "/var/cache/fscache")))))
+
+(define (run-cachefilesd-test)
+ "Run tests in %cachefilesd-os, which has cachefilesd running."
+ (define os
+ (marionette-operating-system
+ %cachefilesd-os
+ #:imported-modules '((gnu services herd))))
+
+ (define vm
+ (virtual-machine os))
+
+ (define test
+ (with-imported-modules '((gnu build marionette))
+ #~(begin
+ (use-modules (srfi srfi-64)
+ (gnu build marionette))
+ (define marionette
+ (make-marionette (list #$vm)))
+
+ (test-runner-current (system-test-runner #$output))
+ (test-begin "cachefilesd")
+
+ (test-assert "service is running"
+ (marionette-eval
+ '(begin
+ (use-modules (gnu services herd))
+ (start-service 'cachefilesd))
+ marionette))
+
+ (test-end))))
+ (gexp->derivation "cachefilesd-test" test))
+
+(define %test-cachefilesd
+ (system-test
+ (name "cachefilesd")
+ (description "Test that the cachefilesd runs when started.")
+ (value (run-cachefilesd-test))))