aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/lightdm.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-07-09 22:30:15 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-07-09 22:51:08 -0400
commit65c77f608916f0c206d0d821db1afa2558c5a74f (patch)
treec2517794018d50a67c03c3dbb5bb7087d1d9e03e /gnu/tests/lightdm.scm
parent2687f7d2c2d18ba4fd0b9dadc6afa658530cd643 (diff)
downloadguix-65c77f608916f0c206d0d821db1afa2558c5a74f.tar
guix-65c77f608916f0c206d0d821db1afa2558c5a74f.tar.gz
gnu: lightdm: Apply patch to fix VNC server address binding ordering.
* gnu/packages/patches/lightdm-vnc-ipv6.patch: New patch file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/display-managers.scm (lightdm): Apply it. * gnu/tests/lightdm.scm (run-lightdm-test): Remove comment and expected fail directive for the "can connect to TCP port 5900 on IPv6" test. Suggested-by: Bruno Victal <mirai@makinata.eu>
Diffstat (limited to 'gnu/tests/lightdm.scm')
-rw-r--r--gnu/tests/lightdm.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/tests/lightdm.scm b/gnu/tests/lightdm.scm
index 6011d2c515..f1c3b67c8a 100644
--- a/gnu/tests/lightdm.scm
+++ b/gnu/tests/lightdm.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>.
+;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>.
;;;
;;; This file is part of GNU Guix.
;;;
@@ -142,10 +142,6 @@
(test-assert "can connect to TCP port 5900 on IPv4"
(wait-for-tcp-port 5900 marionette))
- ;; The VNC server fails to listen to IPv6 due to "Error binding to
- ;; address [::]:5900: Address already in use" (see:
- ;; https://github.com/canonical/lightdm/issues/266).
- (test-expect-fail 1)
(test-assert "can connect to TCP port 5900 on IPv6"
(wait-for-tcp-port 5900 marionette
#:address