aboutsummaryrefslogtreecommitdiff
path: root/gnu/system
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-03-10 23:58:40 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-10 23:58:40 +0100
commit6f58d582432fe46c163f61ddf8f653584f4f7be8 (patch)
tree3ab9b1314089786ac9c76cedc5449151e990636c /gnu/system
parentc9c88118a12b0e22b7369b1dc6b0e2f9db894986 (diff)
downloadguix-6f58d582432fe46c163f61ddf8f653584f4f7be8.tar
guix-6f58d582432fe46c163f61ddf8f653584f4f7be8.tar.gz
More /gnu/store replacements.
* gnu/packages/gcc.scm (gcc-4.7): Change /nix/store in comment. * gnu/system/vm.scm (operating-system-default-contents): Use (%store-prefix) instead of "/nix/store". * guix/derivations.scm (derivation-path->output-path, derivation-path->output-paths): Change to /gnu/store in docstring.
Diffstat (limited to 'gnu/system')
-rw-r--r--gnu/system/vm.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index b6a777353f..a23289a30b 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -373,7 +373,7 @@ such as /etc files."
;; (not 'futime'), so the timestamp of
;; symlinks cannot be changed, and there
;; are symlinks here pointing to
- ;; /nix/store, which is the host,
+ ;; /gnu/store, which is the host,
;; read-only store.
(unless (eq? (stat:type s) 'symlink)
(utime file 0 0 0 0))))
@@ -448,7 +448,7 @@ basic contents of the root file system of OS."
(os-dir -> (derivation->output-path os-drv))
(build-gid (operating-system-build-gid os))
(profile (operating-system-profile-directory os)))
- (return `((directory "/nix/store" 0 ,(or build-gid 0))
+ (return `((directory ,(%store-prefix) 0 ,(or build-gid 0))
(directory "/etc")
(directory "/var/log") ; for dmd
(directory "/var/run/nscd")