aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/vm.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-20 21:14:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-16 15:24:34 +0200
commit222c6b94083e63323303311c6c42b4a8c2b4f392 (patch)
treee276b97a1668900ff0575379e65856b3ff926608 /gnu/system/vm.scm
parent7dff32986228fb515dbda483aaee18de93489e2a (diff)
downloadguix-222c6b94083e63323303311c6c42b4a8c2b4f392.tar
guix-222c6b94083e63323303311c6c42b4a8c2b4f392.tar.gz
Remove the last vestiges of GuixSD.
* gnu/build/vm.scm (load-in-linux-vm): Rename the RNG. * gnu/system/vm.scm (common-qemu-options): Likewise. (system-docker-image): Rename the ROOT-DIRECTORY. * gnu/packages/crypto.scm (eschalot)[arguments]: Use a different arbitrary string. * gnu/packages/wicd.scm (wicd)[arguments]: Remove unused configure flag. * gnu/packages/xorg.scm (xorg-server): Set a more accurate OS vendor.
Diffstat (limited to 'gnu/system/vm.scm')
-rw-r--r--gnu/system/vm.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index 80a8618729..3a5204e11b 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -529,7 +529,7 @@ the operating system."
;; Even as root in a VM, the initializer would fail due to
;; lack of privileges if we use a root-directory that is on
;; a file system that is shared with the host (e.g., /tmp).
- (root-directory "/guixsd-system-root"))
+ (root-directory "/guix-system-root"))
(set-path-environment-variable "PATH" '("bin" "sbin") '(#+tar))
(mkdir root-directory)
(initialize root-directory)
@@ -820,8 +820,8 @@ with '-virtfs' options for the host file systems listed in SHARED-FS."
'())
"-no-reboot"
- "-object" "rng-random,filename=/dev/urandom,id=guixsd-vm-rng"
- "-device" "virtio-rng-pci,rng=guixsd-vm-rng"
+ "-object" "rng-random,filename=/dev/urandom,id=guix-vm-rng"
+ "-device" "virtio-rng-pci,rng=guix-vm-rng"
#$@(map virtfs-option shared-fs)
"-vga std"