aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/accounts.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-03 11:46:43 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-07 20:04:02 +0100
commitf6f67b87c08fe7b901db834c714aceaef2b62b60 (patch)
tree8668cad867dbf8c690b96b6ecb0a58f347e7aa6d /gnu/system/accounts.scm
parentb60e9fb82fd45d48eeeff9a8abc38a6a1a8ab981 (diff)
downloadguix-f6f67b87c08fe7b901db834c714aceaef2b62b60.tar
guix-f6f67b87c08fe7b901db834c714aceaef2b62b60.tar.gz
system: Add (gnu system accounts).
The (gnu system accounts) module is meant to be used both on the build- and on the host-side. * gnu/system/shadow.scm <top level>: Call 'default-shell'. (<user-account>, <user-group>): Move to... * gnu/system/accounts.scm: ... here. New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add system/accounts.scm.
Diffstat (limited to 'gnu/system/accounts.scm')
-rw-r--r--gnu/system/accounts.scm81
1 files changed, 81 insertions, 0 deletions
diff --git a/gnu/system/accounts.scm b/gnu/system/accounts.scm
new file mode 100644
index 0000000000..36ee62e851
--- /dev/null
+++ b/gnu/system/accounts.scm
@@ -0,0 +1,81 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu system accounts)
+ #:use-module (guix records)
+ #:export (user-account
+ user-account?
+ user-account-name
+ user-account-password
+ user-account-uid
+ user-account-group
+ user-account-supplementary-groups
+ user-account-comment
+ user-account-home-directory
+ user-account-create-home-directory?
+ user-account-shell
+ user-account-system?
+
+ user-group
+ user-group?
+ user-group-name
+ user-group-password
+ user-group-id
+ user-group-system?
+
+ default-shell))
+
+
+;;; Commentary:
+;;;
+;;; Data structures representing user accounts and user groups. This is meant
+;;; to be used both on the host side and at run time--e.g., in activation
+;;; snippets.
+;;;
+;;; Code:
+
+(define default-shell
+ ;; Default shell for user accounts (a string or string-valued gexp).
+ (make-parameter "/bin/sh"))
+
+(define-record-type* <user-account>
+ user-account make-user-account
+ user-account?
+ (name user-account-name)
+ (password user-account-password (default #f))
+ (uid user-account-uid (default #f))
+ (group user-account-group) ; number | string
+ (supplementary-groups user-account-supplementary-groups
+ (default '())) ; list of strings
+ (comment user-account-comment (default ""))
+ (home-directory user-account-home-directory)
+ (create-home-directory? user-account-create-home-directory? ;Boolean
+ (default #t))
+ (shell user-account-shell ; gexp
+ (default (default-shell)))
+ (system? user-account-system? ; Boolean
+ (default #f)))
+
+(define-record-type* <user-group>
+ user-group make-user-group
+ user-group?
+ (name user-group-name)
+ (password user-group-password (default #f))
+ (id user-group-id (default #f))
+ (system? user-group-system? ; Boolean
+ (default #f)))