aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/base.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-03-04 21:17:38 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-30 23:18:16 +0200
commited5053188565063b353711772fc2dc3ca50e8568 (patch)
tree00a40adcceb593494f618e2be805ba3aef59e511 /gnu/services/base.scm
parent59878230f4d1ddc017c8e385d71a8851ab677a81 (diff)
downloadguix-ed5053188565063b353711772fc2dc3ca50e8568.tar
guix-ed5053188565063b353711772fc2dc3ca50e8568.tar.gz
services: base: Deprecate 'pam-limits-service' procedure.
* doc/guix.texi (Base Services): Replace pam-limits-service with pam-limits-service-type. * gnu/packages/benchmark.scm (python-locust)[description]: Update index anchor to manual. * gnu/services/base.scm (pam-limits-service-type): Set default value. (pam-limits-service): Deprecate procedure. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/services/base.scm')
-rw-r--r--gnu/services/base.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 5b0b3bb0ab..acbfb879fc 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -246,7 +246,7 @@
kmscon-service-type
pam-limits-service-type
- pam-limits-service
+ pam-limits-service ; deprecated
greetd-service-type
greetd-configuration
@@ -1616,9 +1616,11 @@ information on the configuration file syntax."
(description
"Install the specified resource usage limits by populating
@file{/etc/security/limits.conf} and using the @code{pam_limits}
-authentication module."))))
+authentication module.")
+ (default-value (plain-file "limits.conf" "")))))
-(define* (pam-limits-service #:optional (limits '()))
+(define-deprecated (pam-limits-service #:optional (limits '()))
+ pam-limits-service-type
"Return a service that makes selected programs respect the list of
pam-limits-entry specified in LIMITS via pam_limits.so."
(service pam-limits-service-type