aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish.is@lostca.se>2024-05-26 11:13:23 +0000
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-05-31 17:48:23 +0800
commitfc0d7334cd4fbe4d71fd9f3395f33dd98623f75e (patch)
treea754b22fc2efa059990c15484b3bc685eb8883e2 /gnu/packages
parent01de17143c4830926af6f00f5233d1ba32d7038d (diff)
downloadguix-fc0d7334cd4fbe4d71fd9f3395f33dd98623f75e.tar
guix-fc0d7334cd4fbe4d71fd9f3395f33dd98623f75e.tar.gz
gnu: weechat: Update to 4.3.0.
* gnu/packages/irc.scm (weechat): Update to 4.3.0. [input]: Add dependency on cjson. Change-Id: I30d326638430828c6967a6e6859120300b511a84 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/irc.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index eb01e00827..1b9e974021 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -78,6 +78,7 @@
#:use-module (gnu packages haskell-check)
#:use-module (gnu packages haskell-crypto)
#:use-module (gnu packages haskell-xyz)
+ #:use-module (gnu packages javascript)
#:use-module (gnu packages lua)
#:use-module (gnu packages lxqt)
#:use-module (gnu packages man)
@@ -361,14 +362,14 @@ Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
(define-public weechat
(package
(name "weechat")
- (version "4.2.2")
+ (version "4.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://weechat.org/files/src/weechat-"
version ".tar.xz"))
(sha256
(base32
- "0hdrxcj7pvfryn9lbjdjb5bpq0dxs66mky3grzwhvxghqwi8p5i0"))))
+ "0bc6jvvsprrpnr0bjfi6z0h0z3x0dkq5h38y9nipg7zny85zky9n"))))
(build-system cmake-build-system)
(outputs '("out" "doc"))
(native-inputs
@@ -391,7 +392,8 @@ Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
perl
python
ruby
- tcl))
+ tcl
+ cjson))
(arguments
`(#:configure-flags
(list "-DENABLE_PHP=OFF"