aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJean SIMARD <woshilapin@tuziwo.info>2024-07-27 23:26:52 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 21:48:29 +0100
commitf73dbde86280472fd163bcbebf88f9b20b7f7a71 (patch)
tree64fd7bafb8e9516790e01632084af78b03499346 /gnu/packages
parent7ac644f9962b7c7dbd6418111cbfef7f11b7c703 (diff)
downloadguix-f73dbde86280472fd163bcbebf88f9b20b7f7a71.tar
guix-f73dbde86280472fd163bcbebf88f9b20b7f7a71.tar.gz
gnu: Add go-github-com-emersion-go-webdav.
* gnu/packages/golang-xyz.scm (go-github-com-emersion-go-webdav): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I7062a025e386727c45a8bffce8f059c736111f05
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 90e2c8e72d..71bfeb0be5 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1979,6 +1979,42 @@ for @code{Set}, @code{Get}, @code{Delete} and @code{Len}.")
specified in @url{https://datatracker.ietf.org/doc/html/rfc6350, RFC 6350}.")
(license license:expat)))
+(define-public go-github-com-emersion-go-webdav
+ (package
+ (name "go-github-com-emersion-go-webdav")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-webdav")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ay0x3c1frkj4z3j17s42yvf1hgmg8223qmsyr41yxwz88zsvjlj"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/emersion/go-webdav"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (propagated-inputs
+ (list go-github-com-emersion-go-ical
+ go-github-com-emersion-go-vcard))
+ (home-page "https://github.com/emersion/go-webdav")
+ (synopsis "WebDAV, CalDAV and CardDAV implementations in Golang")
+ (description
+ "This package provides Golang modules implementing WebDAV
+@url{https://tools.ietf.org/html/rfc4918, RFC 4918}, CalDAV
+@url{https://tools.ietf.org/html/rfc4791, RFC 4791} and CardDAV
+@url{https://tools.ietf.org/html/rfc6352, RFC 6352} specifications.")
+ (license license:expat)))
+
(define-public go-github-com-errata-ai-ini
(package
(name "go-github-com-errata-ai-ini")