aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-20 23:12:32 +0100
committerAndrew Tropin <andrew@trop.in>2024-05-30 18:23:31 +0400
commitf5642e7e7cbd39575795a86eebeef3bb1cc09046 (patch)
tree643d238d9fb7417147dcac6a73c9762809ce6b0a /gnu/packages
parentab0af70306b87ccafc8c422ab95f91f19bc1015d (diff)
downloadguix-f5642e7e7cbd39575795a86eebeef3bb1cc09046.tar
guix-f5642e7e7cbd39575795a86eebeef3bb1cc09046.tar.gz
gnu: calceph: Update to 4.0.0.
* gnu/packages/astronomy.scm (calceph): Update to 4.0.0. [source]: Swap to git checkout. [build-system]: Swap to cmake-build-system. [properties]: Remove them. Change-Id: Ic1559a1f956aa90200c911fbee057c55a7fb9874 Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index f7683f6d71..c3894c284a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -191,20 +191,21 @@ reused in several astronomical applications, such as @code{wsclean},
(define-public calceph
(package
(name "calceph")
- (version "3.5.5")
+ (version "4.0.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://www.imcce.fr/content/medias/recherche/equipes/asd/calceph/calceph-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.obspm.fr/imcce_calceph/calceph")
+ (commit (string-append name "_"
+ (string-replace-substring version "." "_")))))
(sha256
- (base32 "1jiaqyir2qcxzjlhk7f9fhrf6snjsiwxznvzdl996xr6m4lzbb7p"))))
- (build-system gnu-build-system)
+ (base32 "1yabdq51plg3dijp68xajhsz395gi2fyp5qkvrj3dgv8d4qw52nw"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
(native-inputs
(list gfortran))
(home-page "https://www.imcce.fr/inpop/calceph")
- (properties `((release-monitoring-url . ,home-page)))
(synopsis "Astronomical library to access the binary planetary ephemeris files")
(description
"The CALCEPH Library is designed to access the binary planetary ephemeris files,