aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 16:15:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:49 +0200
commite5e13d03f03b60b26c0f3b231c31807ccf840273 (patch)
tree3abc7df3305cf2d4f26a8a8d85c3589de74a5048 /gnu/packages
parent1558776ae7d626cf8c6d63dac01555e14567a678 (diff)
downloadguix-e5e13d03f03b60b26c0f3b231c31807ccf840273.tar
guix-e5e13d03f03b60b26c0f3b231c31807ccf840273.tar.gz
gnu: texlive-latex-cmap -> texlive-cmap.
* gnu/packages/tex.scm (texlive-cmap): New variable. (texlive-latex-cmap): Deprecate variable. * gnu/packages/maths.scm (hypre): * gnu/packages/sphinx.scm (python-sphinx): Use new name.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/sphinx.scm2
-rw-r--r--gnu/packages/tex.scm41
3 files changed, 16 insertions, 29 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a462a413ac..6466d1b8c7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5798,7 +5798,7 @@ set.")
texlive-xcolor
texlive-xypic
texlive-listofitems
- texlive-latex-cmap
+ texlive-cmap
texlive-latex-colortbl
texlive-latex-float
texlive-fncychap
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 4e912ae252..906b05e979 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -113,7 +113,7 @@
texlive-ltxcmds
texlive-hyperref
texlive-latex-base ;alltt, atbegshi, makeidx, textcomp
- texlive-latex-cmap
+ texlive-cmap
texlive-fancyhdr
texlive-fancyvrb
texlive-latex-float
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3390978bdf..a1b70ac463 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6569,40 +6569,27 @@ drivers, and VTeX and pdfTeX.")
(define-deprecated-package texlive-latex-changebar texlive-changebar)
-(define-public texlive-latex-cmap
+(define-public texlive-cmap
(package
- (name "texlive-latex-cmap")
+ (name "texlive-cmap")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/cmap"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0m4r52gw9vwsi1pzwh0cy03jxhwizymi4a2fj3jfs5rrvh105r5y"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/cmap")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.tug.org/svn/texlive/tags/texlive-2017.1/\
-Master/texmf-dist/tex/latex/cmap/")
- (synopsis "CMap support for PDF files")
+ (source (texlive-origin
+ name version
+ (list "doc/latex/cmap/"
+ "tex/latex/cmap/")
+ (base32
+ "1hag26l3g9mpmmy1kn7lrnfzzr8k0hpm259qp087smggykvsjc4v")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/cmap")
+ (synopsis "Make PDF files searchable and copyable")
(description
"This package embeds CMap tables into PDF files to make search and
copy-and-paste functions work properly.")
(license license:lppl)))
+(define-deprecated-package texlive-latex-cmap texlive-cmap)
+
(define-public texlive-latex-colortbl
(package
(name "texlive-latex-colortbl")