aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-08 09:33:03 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:23 +0800
commite1110184fffe64331f539f455489f46480825e54 (patch)
tree12751ce322a4db3427f1df8cff76fc23eac8712d /gnu/packages
parentadcc6d35bb201f0e3041fe1d41c5b81a9cd003da (diff)
downloadguix-e1110184fffe64331f539f455489f46480825e54.tar
guix-e1110184fffe64331f539f455489f46480825e54.tar.gz
gnu: kincidenceeditor: Update to 24.05.2.
* gnu/packages/kde-pim.scm (kincidenceeditor): Update to 24.05.2. [inputs]: Remove grantlee and qtbase-5; add kconfigwidgets and kxmlgui. [arguments]: Set #:qtbase to qtbase; Use Gexps. Change-Id: Ie5376412a043ff58c7b6e710f4f600bbe06f28c6
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-pim.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index a85bf53a30..b404ef4178 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -434,14 +434,14 @@ information.")
(define-public kincidenceeditor
(package
(name "kincidenceeditor")
- (version "23.04.3")
+ (version "24.05.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/incidenceeditor-" version ".tar.xz"))
(sha256
- (base32 "1pqfl7gqz7ibpns2gpwqpvzhsba7xj4ilhi4ax1vn3m086iyh3a0"))))
+ (base32 "1kwqr6h2b5jlxkd52g4kdnk78v3xpzqy3d2rl582j7fkhnnsfk40"))))
(properties `((upstream-name . "incidenceeditor")))
(build-system qt-build-system)
(native-inputs
@@ -452,13 +452,13 @@ information.")
akonadi-contacts
akonadi-mime
boost
- grantlee
grantleetheme
kcalendarcore
kcalendarsupport
kcalutils
kcodecs
kcontacts
+ kconfigwidgets
kdbusaddons
kdiagram
keventviews
@@ -475,18 +475,20 @@ information.")
kpimtextedit
ktextaddons
ktextwidgets
+ kxmlgui
kwallet
- libkdepim
- qtbase-5))
+ libkdepim))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "dbus-launch" "ctest" ;; FIXME: tests fails.
- "-E"
- "(akonadi-sqlite-incidencedatetimetest|ktimezonecomboboxtest|testindividualmaildialog)")))))))
+ (list
+ #:qtbase qtbase
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "dbus-launch" "ctest" ;; FIXME: tests fails.
+ "-E"
+ "(akonadi-sqlite-incidencedatetimetest|ktimezonecomboboxtest|testindividualmaildialog)")))))))
(home-page "https://invent.kde.org/pim/incidenceeditor")
(synopsis "KDE PIM library for editing incidences")
(description "This library provides an incidence editor for KDE PIM.")