aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-06 09:50:03 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-12 22:57:46 +0300
commite032a0f38ff3394816fdc29554933ce77c545eff (patch)
treed8283a011025d43783094f90e240261bf7e62465 /gnu/packages
parent9d1b97d7a4ab9c0dbd5808e7859d52cff338f377 (diff)
downloadguix-e032a0f38ff3394816fdc29554933ce77c545eff.tar
guix-e032a0f38ff3394816fdc29554933ce77c545eff.tar.gz
gnu: dool: Update to 1.3.3.
* gnu/packages/admin.scm (dool): Update to 1.3.3. [arguments]<phases>: Fix "check" phase by removing "-f" option from the dool arguments as it leads to failures during tests but works after installation. Don't remove "examples/dstat.py" as it is already removed in the upstream. Change-Id: I22714bc03bf248b97ba8f21835aedb213e1b281b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 398f5b6bfd..2cb50ed4a8 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3544,7 +3544,7 @@ throughput (in the same interval).")
(define-public dool
(package
(name "dool")
- (version "1.3.0")
+ (version "1.3.3")
(source
(origin
(method git-fetch)
@@ -3553,7 +3553,7 @@ throughput (in the same interval).")
(commit (string-append "v" version))))
(file-name (git-file-name "dool" version))
(sha256
- (base32 "1728wxy338gf2l06b0b4j9j8vihadw5whzzj7mi9p3by633h5s8m"))))
+ (base32 "0y5y5c07hgj6v2nvimnwc8myx43li8ib40hdvz7q4q1pdqx3r0jl"))))
(build-system python-build-system)
(arguments
(list
@@ -3562,7 +3562,6 @@ throughput (in the same interval).")
(add-after 'unpack 'remove-symlinks-and-snap-packaging
;; Remove symlinks that make 'ensure-no-mtimes-pre-1980 fail.
(lambda _
- (delete-file "examples/dstat.py")
(delete-file-recursively "packaging/snap")))
(delete 'build)
(replace 'install
@@ -3579,7 +3578,7 @@ throughput (in the same interval).")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "./dool" "--version")
- (invoke "./dool" "-taf" "1" "5")))))))
+ (invoke "./dool" "-ta" "1" "5")))))))
(synopsis "Command line system resource monitoring tool")
(description "Dool is a command line tool to monitor many aspects of your
system: CPU, Memory, Network, Load Average, etc. It also includes a robust