aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 00:18:31 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:00 +0800
commitdaa79cc3c560536d0c0330043aaec1604bdfa626 (patch)
tree9407b04bae09a4edfcddff1f051defc12a1171bb /gnu/packages
parentf026cb1f1eaaf2582ad7a28af6eceaf22c67e39d (diff)
downloadguix-daa79cc3c560536d0c0330043aaec1604bdfa626.tar
guix-daa79cc3c560536d0c0330043aaec1604bdfa626.tar.gz
gnu: kconfig: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (kconfig): Update to 6.3.0. [build-system]: Switch qt-build-system. [arguments]: Set #:qtbase to qtbase; Stop replace check phase; Add check-setup phase. [inputs]: Remove qtbase-5 and qtdeclarative-5. [propagated-inputs]: Add qtdeclarative. [native-inputs]: Remove qttools-5 and xorg-server-for-tests; add qttools. Change-Id: I261f331083b1303387716d681de538e1b2943ef7
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm40
1 files changed, 24 insertions, 16 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 787b5a03a6..01b077677f 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -593,7 +593,7 @@ which can be used to add custom colors to the popup menu.")
(define-public kconfig
(package
(name "kconfig")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -602,23 +602,31 @@ which can be used to add custom colors to the popup menu.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0hghdh4p6cq9ckp4g5jdgd8w47pdsxxvzimrdfjrs71lmy8ydiy2"))))
- (build-system cmake-build-system)
+ "0ybr5l0b9wvzkh3546s3dnv2di0vf3rcf0f6jzbyqlaigfprm04d"))))
+ (build-system qt-build-system)
(native-inputs
- (list dbus extra-cmake-modules inetutils qttools-5
- xorg-server-for-tests))
- (inputs
- (list qtbase-5 qtdeclarative-5))
+ (list dbus extra-cmake-modules inetutils qttools))
+ (propagated-inputs (list qtdeclarative))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests? ;; kconfigcore-kconfigtest fails inconsistently!!
- (setenv "HOME" (getcwd))
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (invoke "ctest" "-E" "(kconfigcore-kconfigtest|\
-kconfiggui-kstandardshortcutwatchertest)")))))))
+ (list
+ #:qtbase qtbase
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-output-to-file "autotests/BLACKLIST"
+ (lambda _
+ (for-each
+ (lambda (name)
+ (display (string-append "[" name "]\n*\n")))
+ (list "testNotifyIllegalObjectPath"
+ "testLocalDeletion"
+ "testNotify"
+ "testSignal"
+ "testDataUpdated"))))
+ (setenv "HOME" (getcwd))
+ (setenv "QT_QPA_PLATFORM" "offscreen")))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Kconfiguration settings framework for Qt")
(description "KConfig provides an advanced configuration system.