aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 00:24:00 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:01 +0800
commitd347fcefb673bfd2caa3ff3cc1f2cb11ec671fd6 (patch)
tree69efea7787860969e0f3fd4cbdc749f646f3859c /gnu/packages
parent7a9e51a669b3a42bd4a9d8a0cd3590b65efc5c0a (diff)
downloadguix-d347fcefb673bfd2caa3ff3cc1f2cb11ec671fd6.tar
guix-d347fcefb673bfd2caa3ff3cc1f2cb11ec671fd6.tar.gz
gnu: kdbusaddons: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (kdbusaddons): Update to 6.3.0. [build-system]: Switch to qt-build-system. [arguments]: Remove patch-source phase; Adjust check phase. [inputs]: Remove qtbase-5, qtx11extras, and kinit-bootstrap; add libxkbcommon. [native-inputs]: Remove qttools-5; add qttools. Change-Id: I57fccc3693997cce92f5c42bb04525dd5a4beb4a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm26
1 files changed, 7 insertions, 19 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index bc29caef36..0a77eb685f 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -705,7 +705,7 @@ many more.")
(define-public kdbusaddons
(package
(name "kdbusaddons")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -714,30 +714,18 @@ many more.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0pzzznyxhi48z5hhdsdxz3vaaihrdshpx65ha2v2nn2gh3ww7ikm"))))
- (build-system cmake-build-system)
+ "00i08baairndj5w6x3rhfxcws0xjd59wn2h08am3ll89xycqjbby"))))
+ (build-system qt-build-system)
(native-inputs
- (list extra-cmake-modules dbus qttools-5))
- (inputs
- (list qtbase-5 qtx11extras kinit-bootstrap))
- ;; kinit-bootstrap: kinit package which does not depend on kdbusaddons.
+ (list extra-cmake-modules dbus qttools))
+ (inputs (list libxkbcommon))
(arguments
- (list #:phases
+ (list #:qtbase qtbase
+ #:phases
#~(modify-phases %standard-phases
- (add-before 'configure 'patch-source
- (lambda* (#:key inputs #:allow-other-keys)
- ;; look for the kdeinit5 executable in kinit's store directory,
- ;; instead of the current application's directory:
- (substitute* "src/kdeinitinterface.cpp"
- (("<< QCoreApplication::applicationDirPath..")
- (string-append
- "<< QString::fromUtf8(\"/"
- (dirname (search-input-file inputs "bin/kdeinit5"))
- "\")" )))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (setenv "DBUS_FATAL_WARNINGS" "0")
(invoke "dbus-launch" "ctest")))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Convenience classes for DBus")