aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-05 00:35:02 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-07-15 09:58:50 -0400
commitd054fbf57dacdf9bd177bb920d7f4c941dc1f9e9 (patch)
tree8d4e10be3519634d43e289e28da41741ea33ef6d /gnu/packages
parent9d4d439b0a455e205da75515852a4147fe378d63 (diff)
downloadguix-d054fbf57dacdf9bd177bb920d7f4c941dc1f9e9.tar
guix-d054fbf57dacdf9bd177bb920d7f4c941dc1f9e9.tar.gz
gnu: gjs: Update to 1.56.2.
* gnu/packages/gnome.scm (gjs): Update to 1.56.2. [arguments]: Adjust pre-check phase. [propagated-inputs]: Replace mozjs-52 with mozjs-60.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a20db29e2a..3ddca75f81 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4812,7 +4812,7 @@ configuration program to choose applications starting on login.")
(define-public gjs
(package
(name "gjs")
- (version "1.52.3")
+ (version "1.56.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4820,7 +4820,7 @@ configuration program to choose applications starting on login.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1z4n15wdz6pbqd2hfzrqc8mmprhv50v4jk43p08v0xv07yldh8ff"))))
+ "1b5321krn89p3f7s2ik6gpfnc61apzljhlnbqky8c88f7n6832ac"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -4840,6 +4840,9 @@ configuration program to choose applications starting on login.")
(substitute* "installed-tests/js/testLocale.js"
((".*toBeDefined.*") "")
((".*expect\\(datestr\\).*") ""))
+ (substitute* "installed-tests/scripts/testCommandLine.sh"
+ (("Valentín") "")
+ (("☭") ""))
#t)))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-resources
@@ -4853,7 +4856,7 @@ configuration program to choose applications starting on login.")
;; These are all in the Requires.private field of gjs-1.0.pc.
`(("cairo" ,cairo)
("gobject-introspection" ,gobject-introspection)
- ("mozjs" ,mozjs-52)))
+ ("mozjs" ,mozjs-60)))
(inputs
`(("gtk+" ,gtk+)
("readline" ,readline)))