aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-28 00:22:08 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:25 +0200
commitcde7374a9eaf0f6ab80cc9dac353892c9bf44245 (patch)
tree0eb866bd2d6e19fe551cf67d4d1ef3d4ffc1de4b /gnu/packages
parentac9798bf4b38189888bc738b90e314d64c7c29b5 (diff)
downloadguix-cde7374a9eaf0f6ab80cc9dac353892c9bf44245.tar
guix-cde7374a9eaf0f6ab80cc9dac353892c9bf44245.tar.gz
gnu: Add texlive-xdvi-bin.
* gnu/packages/tex.scm (texlive-xdvi-bin): New variable. (texlive-xdvi)[propagated-inputs]: Add TEXLIVE-XDVI-BIN. Change-Id: I305992d58740cf23e89aa175fa81109fa1923f04
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5cf49673c4..3e2c194a91 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -74787,6 +74787,7 @@ itself may be shipped out to the DVI file.")
"1iidl3876vyi9k2dyfwd73q5kb53kwckivfyvvxh953n4axbqmi4")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-xdvi-bin))
(home-page "https://ctan.org/pkg/xdvi")
(synopsis "DVI previewer for the X Window System")
(description
@@ -74796,6 +74797,53 @@ that it will build with web2c out of the box.")
;; Xdvi is under MIT terms, whereas Xdvik extensions use BS2-2.
(license (list license:expat license:bsd-2))))
+(define-public texlive-xdvi-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-xdvi-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "utils" '())
+ (delete-other-directories "texk" '("xdvik"))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons "--enable-xdvik" (delete "--enable-web2c" #$flags)))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "texk/xdvik"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (mkdir-p (string-append #$output "/bin"))
+ (with-directory-excursion "texk/xdvik"
+ (invoke "make" "install"))))))))
+ (native-inputs (list pkg-config))
+ (inputs (list freetype ghostscript libxaw texlive-libkpathsea))
+ (propagated-inputs '())
+ (home-page (package-home-page texlive-xdvi))
+ (synopsis "Binaries for @code{texlive-xdvi}}")
+ (description
+ "This package provides the binaries for @code{texlive-xdvi}}.")
+ (license (package-license texlive-xdvi))))
+
(define-public texlive-xetexconfig
(package
(name "texlive-xetexconfig")