aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-10-10 18:14:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-10-11 11:26:01 +0300
commitcdb262e993a2ffdf49f7995cc12fa523d4578c05 (patch)
treed769ae7501beebaed7b9317137e4d237d1cb43b9 /gnu/packages
parent99999ac8ebc4bd5c988ebc88461421aaf55e337a (diff)
downloadguix-cdb262e993a2ffdf49f7995cc12fa523d4578c05.tar
guix-cdb262e993a2ffdf49f7995cc12fa523d4578c05.tar.gz
gnu: mawk: Remove generated file.
* gnu/packages/gawk.scm (mawk)[source]: Adjust snippet to remove pre-generated file. [arguments]: Don't build in parallel. [native-inputs]: Add bison. Change-Id: Ibc1c5128041a20a00ef6445f4e75ce1ff1e8bd97
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gawk.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 436f0f435c..cea58bd415 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -25,6 +25,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages bison)
#:use-module (gnu packages gcc)
#:use-module (gnu packages libsigsegv)
#:use-module (gnu packages multiprecision)
@@ -148,11 +149,17 @@ block-scoped lexical variables."))))
(modules '((guix build utils)))
(snippet
'(begin
+ ;; Delete file generated by bison.
+ (delete-file "parse.c")
;; Prevent tests from hard coding PATH to a bogus value.
(substitute* '("test/mawktest" "test/fpe_test")
(("^PATH=.*")
""))))))
(build-system gnu-build-system)
+ (arguments
+ (list #:parallel-build? #f)) ; Prevent a race condition.
+ (native-inputs
+ (list bison))
(synopsis "Text scanning and processing language")
(description
"@command{mawk} is an interpreter for the Awk programming language.