aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorStefan Reichoer <stefan@xsteve.at>2017-05-25 21:24:52 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-25 23:27:31 +0200
commitca0e62bfe215e49bb5cd1567755cdf0b8d611845 (patch)
tree8981ae1eb751898d4ac59dd05051324e81e8a0d9 /gnu/packages
parent09c36743fa674ff29a55c5191dae35c2c574a4bf (diff)
downloadguix-ca0e62bfe215e49bb5cd1567755cdf0b8d611845.tar
guix-ca0e62bfe215e49bb5cd1567755cdf0b8d611845.tar.gz
gnu: Add python-ansi2html.
* gnu/packages/python.scm (python-ansi2html, python2-ansi2html): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 62fada66a6..d28c2eca65 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2016 Stefan Reichoer <stefan@xsteve.at>
+;;; Copyright © 2016, 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
@@ -13470,6 +13470,33 @@ faster ones are not available.")
to ansi-escaped strings suitable for display in a terminal.")
(license license:expat)))
+(define-public python-ansi2html
+ (package
+ (name "python-ansi2html")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ansi2html" version))
+ (sha256
+ (base32
+ "1wa00zffprb78w1mqq90dk47czz1knanys2a40zbw2vyapd5lp9y"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (home-page "http://github.com/ralphbean/ansi2html")
+ (synopsis "Convert ANSI-decorated console output to HTML")
+ (description
+ "@command{ansi2html} is a Python library and command line utility for
+convering text with ANSI color codes to HTML or LaTeX.")
+ (license license:gpl3+)))
+
+(define-public python2-ansi2html
+ (package-with-python2 python-ansi2html))
+
(define-public python-ddt
(package
(name "python-ddt")