aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlexander I.Grafov (Axel) <grafov@gmail.com>2015-03-17 01:14:16 +0300
committerDavid Thompson <dthompson2@worcester.edu>2015-03-17 20:31:19 -0400
commitca0d2a637be0de78a4f9737e52d1b3a249d833bf (patch)
treec71f3c11097ec2989bc76715a025397be3c3ed3c /gnu/packages
parent7578f6e32a9a1d37813ed5e3ccfeb29d2f6712c9 (diff)
downloadguix-ca0d2a637be0de78a4f9737e52d1b3a249d833bf.tar
guix-ca0d2a637be0de78a4f9737e52d1b3a249d833bf.tar.gz
gnu: Add xcape.
* gnu/packages/xdisorg.scm (xcape): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xdisorg.scm37
1 files changed, 35 insertions, 2 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index fbf1bbf48c..99e2fce926 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -79,8 +79,8 @@ avoiding password prompts when X11 forwarding has already been setup.")
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; Test suite requires a lot of black magic
- #:phases
- (alist-replace 'configure
+ #:phases
+ (alist-replace 'configure
(lambda* (#:key outputs #:allow-other-keys #:rest args)
(setenv "PREFIX" (assoc-ref outputs "out"))
(setenv "LDFLAGS" (string-append "-Wl,-rpath="
@@ -486,3 +486,36 @@ unicode, XFT and may be extended with Perl plugins. It also comes with a
client/daemon pair that lets you open any number of terminal windows from
within a single process.")
(license license:gpl3+)))
+
+(define-public xcape
+ (package
+ (name "xcape")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/alols/" name
+ "/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jkdiaxc6sryrbibdgi2y1c48n4l9xyazhxr16l6h4ibddx95bk9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases (alist-delete 'configure %standard-phases) ; no configure script
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "MANDIR=/share/man/man1"
+ "CC=gcc")))
+ (inputs
+ `(("libxtst" ,libxtst)
+ ("libx11" ,libx11)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://github.com/alols/xcape")
+ (synopsis "Use a modifier key in X.org as another key")
+ (description
+ "This utility for X.org allows to use modifier key as another key when
+pressed and released on its own. The default behaviour is to generate the
+Escape key when Left Control is pressed and released on its own.")
+ (license license:gpl3+)))