aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-12-04 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-12-04 01:00:00 +0100
commitc8316c1e47ce2ace5474cbcda03555cf915b4fce (patch)
tree31a353a810819e1f6bef4147db820120337d451c /gnu/packages
parent0ffa501f2b3e83ae56e9c2bd31418439090e869a (diff)
downloadguix-c8316c1e47ce2ace5474cbcda03555cf915b4fce.tar
guix-c8316c1e47ce2ace5474cbcda03555cf915b4fce.tar.gz
gnu: xdg-desktop-portal-wlr: Install missing documentation.
* gnu/packages/freedesktop.scm (xdg-desktop-portal-wlr)[arguments]: Add a new 'install-documentation phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/freedesktop.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 077d56ad3d..4a4bb18002 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2759,7 +2759,12 @@ for xdg-desktop-portal that is using Qt/KF5.")
(string-append "execl(\"" sh "\", \"" sh "\"")))
(substitute* "src/screencast/screencast.c"
(("execvp\\(\"sh")
- (string-append "execvp(\"" sh)))))))))
+ (string-append "execvp(\"" sh))))))
+ (add-after 'install 'install-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "../source/README.md"
+ (string-append (assoc-ref outputs "out")
+ "/share/doc/" ,name)))))))
(native-inputs
(list cmake pkg-config))
(inputs (list elogind