aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2017-05-25 09:46:51 +0200
committerArun Isaac <arunisaac@systemreboot.net>2017-05-25 23:26:47 +0530
commitc10d887dd98f2c8893b3acda10db650c81898134 (patch)
treef654bd8f6c4bb4b452829a839409bb9c56cb7568 /gnu/packages
parent60793e3732235af92de37602fcf2e306ef290077 (diff)
downloadguix-c10d887dd98f2c8893b3acda10db650c81898134.tar
guix-c10d887dd98f2c8893b3acda10db650c81898134.tar.gz
gnu: emacs-exwm: Update to 0.14.
* gnu/packages/emacs.scm (emacs-exwm): Update to 0.14. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8c3950d31d..4160ead598 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4544,7 +4544,7 @@ It should enable you to implement low-level X11 applications.")
(define-public emacs-exwm
(package
(name "emacs-exwm")
- (version "0.13")
+ (version "0.14")
(synopsis "Emacs X window manager")
(source (origin
(method url-fetch)
@@ -4552,7 +4552,7 @@ It should enable you to implement low-level X11 applications.")
version ".tar"))
(sha256
(base32
- "0n1wzy6chh024r0yaywjbf7mdsrxs6hrfycv5v0ps0drf6q3zldc"))))
+ "14hjjpbasm84p54fxy73fg7g1fdwqkvisdw8dwwgzkflmd647mkx"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-xelb" ,emacs-xelb)))
@@ -4586,12 +4586,9 @@ It should enable you to implement low-level X11 applications.")
TryExec=~@*~a~@
Type=Application~%" ,name ,synopsis exwm-executable)))
;; Add a shell wrapper to bin
- ;; Set DISPLAY variable to work around
- ;; https://github.com/ch11ng/exwm/issues/213
(with-output-to-file exwm-executable
(lambda _
(format #t "#!~a ~@
- export DISPLAY=:0 ~@
~a +SI:localuser:$USER ~@
exec ~a --exit-with-session ~a \"$@\" --eval '~s' ~%"
(string-append (assoc-ref inputs "bash") "/bin/sh")