aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 14:31:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:36 +0200
commitbcabbce9ffaa441aeed05ba9bba816887b214a1f (patch)
tree0086acb67f8a0d46746369ad32d09b89e69ba756 /gnu/packages
parenta94bb92f07f322e8bccd0a6159b79dc60d54d517 (diff)
downloadguix-bcabbce9ffaa441aeed05ba9bba816887b214a1f.tar
guix-bcabbce9ffaa441aeed05ba9bba816887b214a1f.tar.gz
gnu: texlive-lastpage: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-lastpage!): Remove SIMPLE-TEXLIVE-PACKAGE call.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 17 insertions, 20 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 14f60f8f45..f0c224b224 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13695,28 +13695,25 @@ underscores), and hyphenation of text typeset in monospaced (e.g.,
(define-deprecated-package texlive-latex-hyphenat texlive-hyphenat)
(define-public texlive-lastpage
- (let ((template (simple-texlive-package
- "texlive-lastpage"
- (list "doc/latex/lastpage/"
- "source/latex/lastpage/"
- "tex/latex/lastpage/")
- (base32
- "1cmzl0jkid4w60bjlyxrc5bynbc3lwq5nr77rsip0q9hprxykxks"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ #t) "latex/lastpage")
- ((#:build-targets _ '()) '(list "lastpage.ins"))))
- (home-page "https://ctan.org/pkg/lastpage")
- (synopsis "Reference last page for Page N of M type footers")
- (description
- "This package enables referencing the number of pages in a LaTeX
-document through the introduction of a new label which can be referenced like
+ (package
+ (name "texlive-lastpage")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/lastpage/" "source/latex/lastpage/"
+ "tex/latex/lastpage/")
+ (base32
+ "1cmzl0jkid4w60bjlyxrc5bynbc3lwq5nr77rsip0q9hprxykxks")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/lastpage")
+ (synopsis "Reference last page for Page N of M type footers")
+ (description
+ "This package enables referencing the number of pages in a LaTeX document
+through the introduction of a new label which can be referenced like
@code{\\pageref{LastPage}} to give a reference to the last page of a document.
It is particularly useful in the page footer that says: @samp{Page N of M}.")
- (license license:lppl1.3+))))
+ (license license:lppl1.3+)))
(define-deprecated-package texlive-latex-lastpage texlive-lastpage)