aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2024-07-03 16:58:00 +0900
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:47:26 +0300
commitbad70dad87b0489bfdeb25744db55c3f25fcbd87 (patch)
tree25d7a23124c319ee804254ca0e8a08cb9cb1766b /gnu/packages
parent59e445ca17b6e328867a08a5b454d07b50f339a2 (diff)
downloadguix-bad70dad87b0489bfdeb25744db55c3f25fcbd87.tar
guix-bad70dad87b0489bfdeb25744db55c3f25fcbd87.tar.gz
gnu: Add rust-pyo3-0.21.
* gnu/packages/crates-io.scm (rust-pyo3-0.21): New variable. (rust-pyo3-0.20): Inherit from rust-pyo3-0.21. Update to 0.20.3. Change-Id: Icfabbd32c1c673cd3459122cd5d5388e6dcb4137 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm63
1 files changed, 55 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f46fb936ba..a6eda94596 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -58534,22 +58534,23 @@ extension to python.")
("rust-syn" ,rust-syn-1))))
(native-inputs (list python))))
-(define-public rust-pyo3-0.20
+(define-public rust-pyo3-0.21
(package
(name "rust-pyo3")
- (version "0.20.2")
+ (version "0.21.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "pyo3" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1q3g7ppg2qskigbgqg3w9280klkil5is9hhyps1ykl2hb1xdr2cs"))))
+ (base32 "1n39y183jfqbyvimscqr0ysxxa6804pn46ivw048ww91lnb0pq55"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
("rust-cfg-if" ,rust-cfg-if-1)
("rust-chrono" ,rust-chrono-0.4)
+ ("rust-chrono-tz" ,rust-chrono-tz-0.6)
("rust-either" ,rust-either-1)
("rust-eyre" ,rust-eyre-0.6)
("rust-hashbrown" ,rust-hashbrown-0.14)
@@ -58561,22 +58562,24 @@ extension to python.")
("rust-num-bigint" ,rust-num-bigint-0.4)
("rust-num-complex" ,rust-num-complex-0.4)
("rust-parking-lot" ,rust-parking-lot-0.12)
- ("rust-pyo3-build-config" ,rust-pyo3-build-config-0.20)
- ("rust-pyo3-ffi" ,rust-pyo3-ffi-0.20)
- ("rust-pyo3-macros" ,rust-pyo3-macros-0.20)
+ ("rust-portable-atomic" ,rust-portable-atomic-1)
+ ("rust-pyo3-build-config" ,rust-pyo3-build-config-0.21)
+ ("rust-pyo3-ffi" ,rust-pyo3-ffi-0.21)
+ ("rust-pyo3-macros" ,rust-pyo3-macros-0.21)
("rust-rust-decimal" ,rust-rust-decimal-1)
("rust-serde" ,rust-serde-1)
("rust-smallvec" ,rust-smallvec-1)
("rust-unindent" ,rust-unindent-0.2))
#:cargo-development-inputs (("rust-assert-approx-eq" ,rust-assert-approx-eq-1)
("rust-chrono" ,rust-chrono-0.4)
+ ("rust-chrono-tz" ,rust-chrono-tz-0.6)
+ ("rust-futures" ,rust-futures-0.3)
("rust-proptest" ,rust-proptest-1)
("rust-rayon" ,rust-rayon-1)
("rust-send-wrapper" ,rust-send-wrapper-0.6)
("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1)
- ("rust-trybuild" ,rust-trybuild-1)
- ("rust-widestring" ,rust-widestring-0.5))))
+ ("rust-trybuild" ,rust-trybuild-1))))
(inputs (list python))
(home-page "https://github.com/pyo3/pyo3")
(synopsis "Rust bindings for the Python interpreter")
@@ -58586,6 +58589,50 @@ creating native Python extension modules. Running and interacting with
Python code from a Rust binary is also supported.")
(license (list license:expat license:asl2.0))))
+(define-public rust-pyo3-0.20
+ (package
+ (inherit rust-pyo3-0.21)
+ (name "rust-pyo3")
+ (version "0.20.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pyo3" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0cw2pgab0pq5gd98nhv18xgxvyigygspla6c8mfycmwisjbbpgak"))))
+ (arguments
+ `(#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-either" ,rust-either-1)
+ ("rust-eyre" ,rust-eyre-0.6)
+ ("rust-hashbrown" ,rust-hashbrown-0.14)
+ ("rust-indexmap" ,rust-indexmap-2)
+ ("rust-indoc" ,rust-indoc-2)
+ ("rust-inventory" ,rust-inventory-0.3)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-memoffset" ,rust-memoffset-0.9)
+ ("rust-num-bigint" ,rust-num-bigint-0.4)
+ ("rust-num-complex" ,rust-num-complex-0.4)
+ ("rust-parking-lot" ,rust-parking-lot-0.12)
+ ("rust-pyo3-build-config" ,rust-pyo3-build-config-0.20)
+ ("rust-pyo3-ffi" ,rust-pyo3-ffi-0.20)
+ ("rust-pyo3-macros" ,rust-pyo3-macros-0.20)
+ ("rust-rust-decimal" ,rust-rust-decimal-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-smallvec" ,rust-smallvec-1)
+ ("rust-unindent" ,rust-unindent-0.2))
+ #:cargo-development-inputs (("rust-assert-approx-eq" ,rust-assert-approx-eq-1)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-proptest" ,rust-proptest-1)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-send-wrapper" ,rust-send-wrapper-0.6)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-trybuild" ,rust-trybuild-1)
+ ("rust-widestring" ,rust-widestring-0.5))))))
+
(define-public rust-pyo3-0.19
(package
(inherit rust-pyo3-0.20)