aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 00:27:27 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:01 +0800
commitb90ded254fdbc65326293ee773f754e5508258e2 (patch)
tree51e1d12cf999c45e10ddd01b247341017293f6f6 /gnu/packages
parent7b4ae4a5119657480cd802f69b16106e6cd6f997 (diff)
downloadguix-b90ded254fdbc65326293ee773f754e5508258e2.tar
guix-b90ded254fdbc65326293ee773f754e5508258e2.tar.gz
gnu: kwindowsystem: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (kwindowsystem): Update to 6.3.0. [inputs]: Remove libxrender, qtbase-5, and qtx11extras; add qtbase, qtdeclarative, qtwayland, wayland-protocols, plasma-wayland-protocols, libxkbcommon, and wayland. [native-inputs]: Remove qttools-5; add wayland and qttools. [arguments]: Adjust check phase. Change-Id: Iad2482d91f037a2a178c5d257c140b904425f84b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index e3fee4f479..771f5f8875 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1216,7 +1216,7 @@ configuration pages, message boxes, and password requests.")
(define-public kwindowsystem
(package
(name "kwindowsystem")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1225,19 +1225,24 @@ configuration pages, message boxes, and password requests.")
name "-" version ".tar.xz"))
(sha256
(base32
- "03xbsf1pmswd2kpn3pdszp4vndclsh7j02fp22npxaxllmfr4va9"))))
+ "1fdax3c2q3fm56pvr99z0rwf1nwz7jmksblj9d42gg1l55ckrqs0"))))
(build-system cmake-build-system)
(native-inputs
(list extra-cmake-modules
pkg-config
+ wayland; for wayland-scanner
dbus ; for the tests
- openbox ; for the tests
- qttools-5
+ openbox ; for the test
+ qttools
xorg-server-for-tests)) ; for the tests
(inputs
- (list libxrender
- qtbase-5
- qtx11extras
+ (list qtbase
+ qtdeclarative
+ qtwayland
+ wayland-protocols
+ plasma-wayland-protocols
+ libxkbcommon
+ wayland
xcb-util-keysyms
xcb-util-wm))
(arguments
@@ -1248,7 +1253,7 @@ configuration pages, message boxes, and password requests.")
(lambda* (#:key tests? #:allow-other-keys)
;; The test suite requires a running window anager
(when tests?
- (setenv "XDG_RUNTIME_DIR" "/tmp")
+ (setenv "XDG_RUNTIME_DIR" (getcwd))
(system "Xvfb :1 -ac -screen 0 640x480x24 &")
(setenv "DISPLAY" ":1")
(sleep 5) ;; Give Xvfb a few moments to get on it's feet