aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-09 21:34:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 13:15:39 +0100
commitb6332821c211a6e788d5a9ff576b56e0e4038aaa (patch)
tree78efae707a899b485e4b3123b091780eec448e28 /gnu/packages
parente42c5a247c278c0eb402b9d9237ba56ba38d69d3 (diff)
downloadguix-b6332821c211a6e788d5a9ff576b56e0e4038aaa.tar
guix-b6332821c211a6e788d5a9ff576b56e0e4038aaa.tar.gz
gnu: go-github-com-rogpeppe-go-internal: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-rogpeppe-go-internal): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Id061201d8454371eedff5f2115a36cf3d9ccb0b3
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm47
-rw-r--r--gnu/packages/golang.scm46
2 files changed, 47 insertions, 46 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c89798f15f..26fdf7671f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4735,6 +4735,53 @@ routines querying a database but without sending too much queries in order to
not overload the given database.")
(license license:expat)))
+(define-public go-github-com-rogpeppe-go-internal
+ (package
+ (name "go-github-com-rogpeppe-go-internal")
+ (version "1.12.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rogpeppe/go-internal")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18szjxqrjjvgsvyjbkqs6xw4bvg5nn1myg5hhb5qzwz5xl4wvw5a"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/rogpeppe/go-internal"
+ ;; Source-only package
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'build))))
+ (propagated-inputs
+ (list go-github-com-pkg-diff))
+ (home-page "https://github.com/rogpeppe/go-internal/")
+ (synopsis "Internal packages from the Go standard library")
+ (description "This repository factors out an opinionated selection of
+internal packages and functionality from the Go standard library. Currently
+this consists mostly of packages and testing code from within the Go tool
+implementation.
+
+Included are the following:
+@itemize
+@item dirhash: calculate hashes over directory trees the same way that the Go tool does.
+@item goproxytest: a GOPROXY implementation designed for test use.
+@item gotooltest: Use the Go tool inside test scripts (see testscript below)
+@item imports: list of known architectures and OSs, and support for reading import import statements.
+@item modfile: read and write go.mod files while preserving formatting and comments.
+@item module: module paths and versions.
+@item par: do work in parallel.
+@item semver: semantic version parsing.
+@item testenv: information on the current testing environment.
+@item testscript: script-based testing based on txtar files
+@item txtar: simple text-based file archives for testing.
+@end itemize\n")
+ (license license:bsd-3)))
+
(define-public go-github-com-schollz-progressbar-v3
(package
(name "go-github-com-schollz-progressbar-v3")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9a7859236e..d02f2d96e9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7086,52 +7086,6 @@ losing type information. The primary intended use is for implementing
configuration languages, but other uses may be possible too.")
(license license:expat)))
-(define-public go-github-com-rogpeppe-go-internal
- (package
- (name "go-github-com-rogpeppe-go-internal")
- (version "1.12.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rogpeppe/go-internal")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "18szjxqrjjvgsvyjbkqs6xw4bvg5nn1myg5hhb5qzwz5xl4wvw5a"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/rogpeppe/go-internal"
- ; Source-only package
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'build))))
- (propagated-inputs
- (list go-github-com-pkg-diff))
- (home-page "https://github.com/rogpeppe/go-internal/")
- (synopsis "Internal packages from the Go standard library")
- (description "This repository factors out an opinionated selection of
-internal packages and functionality from the Go standard library. Currently
-this consists mostly of packages and testing code from within the Go tool
-implementation.
-
-Included are the following:
-@itemize
-@item dirhash: calculate hashes over directory trees the same way that the Go tool does.
-@item goproxytest: a GOPROXY implementation designed for test use.
-@item gotooltest: Use the Go tool inside test scripts (see testscript below)
-@item imports: list of known architectures and OSs, and support for reading import import statements.
-@item modfile: read and write go.mod files while preserving formatting and comments.
-@item module: module paths and versions.
-@item par: do work in parallel.
-@item semver: semantic version parsing.
-@item testenv: information on the current testing environment.
-@item testscript: script-based testing based on txtar files
-@item txtar: simple text-based file archives for testing.
-@end itemize\n")
- (license license:bsd-3)))
-
(define-public go-gopkg-in-errgo-fmt-errors
(package
(name "go-gopkg-in-errgo-fmt-errors")