aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAfkhami, Navid <Navid.Afkhami@mdc-berlin.de>2024-08-19 15:14:59 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-11-01 12:02:11 +0100
commitb579bc42dd7b426c6bb520a70c2d042af28800dc (patch)
tree8a5e31c4270bc798b4ab14c815a0eb2fd75e24ff /gnu/packages
parente5924771d10ccb311070163e23a96e919ed46434 (diff)
downloadguix-b579bc42dd7b426c6bb520a70c2d042af28800dc.tar
guix-b579bc42dd7b426c6bb520a70c2d042af28800dc.tar.gz
gnu: Add r-cca.
* gnu/packages/cran.scm (r-cca): New variable. Change-Id: Icc3411c5b57e97d8fc9f6e749f280b62572c32b3 Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 43e4cf416b..5209fcc9ce 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -42299,6 +42299,28 @@ least four days in the calendar year. This package provides functionality to
convert dates to MMWR day, week, and year and the reverse.")
(license license:gpl2+)))
+(define-public r-cca
+ (package
+ (name "r-cca")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "CCA" version))
+ (sha256
+ (base32 "0r1f7m64608hq6bpw36wsw6fr4s8bj26x4062brqgn5dbpqlgczk"))))
+ (properties `((upstream-name . "CCA")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-fda r-fields))
+ (home-page "https://cran.r-project.org/package=CCA")
+ (synopsis "Canonical correlation analysis")
+ (description
+ "This package contains a set of functions that extend the @code{cancor}
+function. These functions provide new numerical and graphical outputs. It
+also includes a regularized extension of the canonical correlation analysis to
+deal with datasets with more variables than observations.")
+ (license license:gpl2+)))
+
(define-public r-cccd
(package
(name "r-cccd")