aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-10-15 12:53:50 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-10-15 12:53:50 +0200
commitadaaa32658a395022c1b4fb9f3c61e6ed6c0f247 (patch)
tree1d5b27c1794fbc292f78c3c59e9fe885b8131d2c /gnu/packages
parent7c93145d9e027cb571bf7634192dfae5468ecde2 (diff)
downloadguix-adaaa32658a395022c1b4fb9f3c61e6ed6c0f247.tar
guix-adaaa32658a395022c1b4fb9f3c61e6ed6c0f247.tar.gz
gnu: Add perl-yaml-syck.
* gnu/packages/perl.scm (perl-yaml-syck): New variable. Change-Id: I49fd33875f50357834262a8fc8d8a117c3f492b6
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 31576dedf9..1c300d1135 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
;;; Copyright © 2016, 2018, 2020, 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2016, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2016, 2020, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2017, 2018, 2020-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
@@ -12240,6 +12240,25 @@ for use in reading and writing CPAN metadata files like META.yml and
MYMETA.yml.")
(license (package-license perl))))
+(define-public perl-yaml-syck
+ (package
+ (name "perl-yaml-syck")
+ (version "1.34")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/T/TO/TODDR/YAML-Syck-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0na1wg3d7ykzy5i44w6i1s37ymq6x0cvcc9gzvmri9xxmv65d4fc"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/YAML-Syck")
+ (synopsis "Fast, lightweight YAML loader and dumper")
+ (description "@code{YAML::Syck} provides a Perl interface to the libsyck
+data serialization library. It exports the Dump and Load functions for
+converting Perl data structures to YAML strings, and the other way around.")
+ (license license:x11)))
+
(define-public perl-module-build
(package
(name "perl-module-build")