aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-17 12:41:07 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-19 14:51:34 +0100
commita78f535d9ab9c438ed2451f1af891a1458a7b985 (patch)
treefd3f3b9786f5f86789227b9d6de0340da15574af /gnu/packages
parent285d8f0dca62d2b2865dfa4787baca406c70671f (diff)
downloadguix-a78f535d9ab9c438ed2451f1af891a1458a7b985.tar
guix-a78f535d9ab9c438ed2451f1af891a1458a7b985.tar.gz
gnu: Add perl-svg.
* gnu/packages/perl.scm (perl-svg): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 0b3666107e..c9f45dc529 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2795,6 +2795,28 @@ The idea is just to fool caller(). All the really naughty bits of Tcl's
uplevel() are avoided.")
(license (package-license perl))))
+(define-public perl-svg
+ (package
+ (name "perl-svg")
+ (version "2.63")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/S/SZ/SZABGAB/SVG-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12cbncsfxbwg1w3p1qmymfbqdb22kmyajxzdnxnxbq5xjl6yncha"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/SVG")
+ (synopsis "Perl extension for generating SVG documents")
+ (description "SVG is a Perl module which generates a nested data structure
+containing the DOM representation of an SVG (Scalable Vector Graphics) image.
+Using SVG, you can generate SVG objects, embed other SVG instances into it,
+access the DOM object, create and access Javascript, and generate SMIL
+animation content.")
+ (license (package-license perl))))
+
(define-public perl-sys-cpu
(package
(name "perl-sys-cpu")