aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorhumanitiesNerd <catonano@gmail.com>2017-03-12 21:02:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-13 19:36:56 +0100
commita71c863834448e2645518b31b60a96ef488dd761 (patch)
tree9adee92e76e0b6f85131b4f20f4b4d6f88367cb5 /gnu/packages
parent78c556636509515080a66511f1998a974d0e2623 (diff)
downloadguix-a71c863834448e2645518b31b60a96ef488dd761.tar
guix-a71c863834448e2645518b31b60a96ef488dd761.tar.gz
gnu: Add python-flask-login.
* gnu/packages/python.scm (python-flask-login, python2-flask-login): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f307b5c5b5..333cfd54e9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13646,3 +13646,32 @@ It comes with safe defaults and easily configurable options.")
(define-public python2-flask-htmlmin
(package-with-python2 python-flask-htmlmin))
+
+(define-public python-flask-login
+ (package
+ (name "python-flask-login")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/maxcountryman/flask-login/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pdqp7a2gyb7k06xda004x0fi2w66s6kn2i0ndkqndmg12d83f9w"))))
+ (arguments
+ ;; Tests fail PEP8 compliance. See:
+ ;; https://github.com/maxcountryman/flask-login/issues/340
+ `(#:tests? #f))
+ (build-system python-build-system)
+ (home-page "https://github.com/maxcountryman/flask-login")
+ (synopsis "User session management for Flask")
+ (description
+ "@code{Flask-Login} provides user session management for Flask. It
+handles the common tasks of logging in, logging out, and remembering your
+users' sessions over extended periods of time.")
+ (license license:expat)))
+
+(define-public python2-flask-login
+ (package-with-python2 python-flask-login))