aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJean SIMARD <woshilapin@tuziwo.info>2024-07-27 13:07:57 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 21:48:28 +0100
commita4b1e5d348ba86b3d245e3647034c3e826f141c5 (patch)
tree27bcdd159aaa18359c99e6f9def184a9b314bb8d /gnu/packages
parentf400b64826caf6f5454cbcb1c7e891c870afb02f (diff)
downloadguix-a4b1e5d348ba86b3d245e3647034c3e826f141c5.tar
guix-a4b1e5d348ba86b3d245e3647034c3e826f141c5.tar.gz
gnu: Add go-github-com-boltdb-bolt.
* gnu/packages/golang.scm (go-github-com-boltdb-bolt): New variable. Change-Id: I931688d0c32fc16a50cb58d4a7fef627d4e584a5 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 24cf0ec329..d06ca7a25a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
+;;; Copyright © 2024 Jean Simard <woshilapin@tuziwo.info>
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;; Copyright © 2024 Luis Higino <luishenriquegh2701@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
@@ -1179,6 +1180,35 @@ information and periodically output metrics")
quantiles over an unbounded data stream within low memory and CPU bounds.")
(license license:bsd-2)))
+;; XXX: This repository has been archived by the owner on Mar 9, 2019. It is
+;; now read-only.
+(define-public go-github-com-boltdb-bolt
+ (package
+ (name "go-github-com-boltdb-bolt")
+ (version "1.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/boltdb/bolt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z7j06lijfi4y30ggf2znak2zf2srv2m6c68ar712wd2ys44qb3r"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:tests? #f ;tests are broken in upstream
+ #:import-path "github.com/boltdb/bolt"))
+ (home-page "https://github.com/boltdb/bolt")
+ (synopsis "Embedded key/value database for Golang")
+ (description
+ "Bolt is a pure Go key/value store inspired by
+@url{http://symas.com/mdb/, Howard Chu's LMDB project}. The goal of the
+project is to provide a simple, fast, and reliable database for projects that
+don't require a full database server such as Postgres or MySQL.")
+ (license license:expat)))
+
(define-public go-github-com-briandowns-spinner
(package
(name "go-github-com-briandowns-spinner")