aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-28 07:20:20 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:26 +0200
commit9ccd4f8dd4c5ae2c079dbaa282da15e2f57714fc (patch)
tree022bf03bb30da3403a3c9f0ae49fe664b5afe61a /gnu/packages
parentc0b05e765fb991de9e04a27f5404728d16fa2180 (diff)
downloadguix-9ccd4f8dd4c5ae2c079dbaa282da15e2f57714fc.tar
guix-9ccd4f8dd4c5ae2c079dbaa282da15e2f57714fc.tar.gz
gnu: Add texlive-metapost-bin.
* gnu/packages/tex.scm (texlive-metapost-bin): New variable. (texlive-metapost)[propagated-inputs]: Add TEXLIVE-METAPOST-BIN. Change-Id: I6826d2c74d107ef5d58651b1bb6838aec0fdb6aa
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c44a863587..8ae6f02c86 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -57843,7 +57843,7 @@ The package contains both the original TrueType font and the derived Type
"0i6mjq59n7vll81m7r2k83x0q6xx7cg6qcia46298zqc0b0l3qb0")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (propagated-inputs (list texlive-kpathsea))
+ (propagated-inputs (list texlive-kpathsea texlive-metapost-bin))
(home-page "https://ctan.org/pkg/metapost")
(synopsis "Create scalable illustrations")
(description
@@ -57852,6 +57852,34 @@ technical illustrations. Its output is scalable PostScript or SVG, rather
than the bitmaps Metafont creates.")
(license license:lppl)))
+(define-public texlive-metapost-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-metapost-bin")
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(delete "--enable-web2c" #$flags))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'install
+ (lambda _
+ (let ((bin (string-append #$output "/bin")))
+ (with-directory-excursion "texk/web2c"
+ (invoke "make" "mpost")
+ (install-file "mpost" bin))
+ (with-directory-excursion bin
+ (for-each (lambda (link) (symlink "mpost" link))
+ '("dvitomp" "mfplain" "r-mpost"))))))))))
+ (native-inputs (list pkg-config))
+ (inputs (modify-inputs (package-inputs texlive-bin)
+ (append cairo mpfr)))
+ (home-page (package-home-page texlive-metapost))
+ (synopsis "Binary for @code{texlive-metapost}")
+ (description
+ "This package provides the binary for @code{texlive-metapost}.")
+ (license (package-license texlive-metapost))))
+
(define-public texlive-acmart
(package
(name "texlive-acmart")