aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 15:50:03 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:57 +0100
commit96d3f5240b0a4bf40c3acc6eb05f18dc30dd1efb (patch)
tree3676ebba5f6716459b60efc887eea3747ff5bb23 /gnu/packages
parent03062c7a9fd74d625639e1a325e9cb58d1cd74e3 (diff)
downloadguix-96d3f5240b0a4bf40c3acc6eb05f18dc30dd1efb.tar
guix-96d3f5240b0a4bf40c3acc6eb05f18dc30dd1efb.tar.gz
gnu: go-golang-org-x-oauth2: Update to 0.21.0.
* gnu/packages/golang.scm (go-golang-org-x-oauth2): Update to 0.21.0. [propagated-inputs]: Remove go-golang-org-x-net; add go-github-com-google-go-cmp-cmp. Change-Id: I8213829fbd012c4ab8246a4a6fe794f6371ef65b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1298a8c58b..acf16071ff 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3263,32 +3263,29 @@ editor.")
(license license:bsd-3)))
(define-public go-golang-org-x-oauth2
- (let ((commit "0f29369cfe4552d0e4bcddc57cc75f4d7e672a33")
- (revision "1"))
(package
(name "go-golang-org-x-oauth2")
- (version (git-version "0.0.0" revision commit))
+ (version "0.21.0")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://go.googlesource.com/oauth2")
- (commit commit)))
- (file-name (string-append "go.googlesource.com-oauth2-"
- version "-checkout"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "06jwpvx0x2gjn2y959drbcir5kd7vg87k0r1216abk6rrdzzrzi2"))))
+ "0pzpa9jqrfxxhxi1w7n5ljnvr9qfw42hzavz62fc9i6z9vk2466k"))))
(build-system go-build-system)
(arguments
`(#:import-path "golang.org/x/oauth2"))
(propagated-inputs
(list go-cloud-google-com-go-compute-metadata
- go-golang-org-x-net))
+ go-github-com-google-go-cmp-cmp))
(home-page "https://go.googlesource.com/oauth2")
(synopsis "Client implementation of the OAuth 2.0 spec")
(description "This package contains a client implementation for OAuth 2.0
spec in Go.")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public go-github-com-jpillora-backoff
(let ((commit