aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-19 14:27:15 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-22 22:47:23 +0100
commit93fb74c2ed58c48b81499373b262da40208525a9 (patch)
tree821d21aa4e5916d88d4b995e2fa067f40deeec11 /gnu/packages
parentf1af3a542c4ec71e16580f9af92a2429601aec32 (diff)
downloadguix-93fb74c2ed58c48b81499373b262da40208525a9.tar
guix-93fb74c2ed58c48b81499373b262da40208525a9.tar.gz
gnu: go-github-com-jdkato-twine: Enable tests.
* gnu/packages/golang-xyz.scm (go-github-com-jdkato-twine) [source]: Add snippet adjusting changed upstream module import path. [arguments]: <#:phases>: Remove 'build and 'patch-module-import-path phases. Add 'disable-failing-tests phase. Use custom 'check phase. Change-Id: I8553705ca0b812c772005460b242ce47b0c65ced
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c5cfc64d6a..6560f43578 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2644,33 +2644,33 @@ and stop units of work, which may receive @code{Close} signals from many clients
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1hbpxcrcsbi975lklrhzyzk0fzn79pxicvfyf2sckmd2n6jb4ayy"))))
+ (base32 "1hbpxcrcsbi975lklrhzyzk0fzn79pxicvfyf2sckmd2n6jb4ayy"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Module name has been changed upstream.
+ (substitute* (find-files "." "\\.go$")
+ (("gopkg.in/neurosnap/sentences.v1")
+ "github.com/neurosnap/sentences"))))))
(build-system go-build-system)
(arguments
(list
- ;; FIXME: Adjust tests sute or check with upstram:
- ;; === Failed
- ;; === FAIL: nlp/segment TestGoldenRules (0.00s)
- ;; segment_test.go:143: 25. Double quotations inside sentence
- ;; segment_test.go:144: Actual: [She turned to him, "This is great." she said.]
- ;; segment_test.go:145: Actual: 2, Expected: 1
- ;; segment_test.go:146: ===
- #:tests? #f
#:import-path "github.com/jdkato/twine"
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'patch-module-import-path
- (lambda* (#:key import-path #:allow-other-keys)
- (with-directory-excursion (string-append "src/" import-path)
- (substitute* (find-files "." "\\.go$")
- (("gopkg.in/neurosnap/sentences.v1")
- "github.com/neurosnap/sentences")))))
- (replace 'build
- (lambda* (#:key import-path #:allow-other-keys)
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? import-path #:allow-other-keys)
(with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "build" "-v" "-x" "-ldflags=-s -w" "-trimpath" "./...")))))))
- (native-inputs
- (list gotestsum))
+ (substitute* "nlp/segment/segment_test.go"
+ (("TestGoldenRules") "OffTestGoldenRules")))))
+ ;; XXX: Workaround for go-build-system's lack of Go modules
+ ;; support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(propagated-inputs
(list go-github-com-montanaflynn-stats
go-github-com-neurosnap-sentences