aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-01 22:09:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-01 22:21:58 +0200
commit8ee245807236e7b52b06614828aea7896e517947 (patch)
treefcf8c28fd897c5e53289c5e0f2b6237a973f3c6d /gnu/packages
parent0f0609300713a949e62a465d6b0f11c9268e7cd0 (diff)
downloadguix-8ee245807236e7b52b06614828aea7896e517947.tar
guix-8ee245807236e7b52b06614828aea7896e517947.tar.gz
gnu: emacs-pcre2el: Update to 1.9.
* gnu/packages/emacs-xyz.scm (emacs-pcre2el): Update to 1.9.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 18 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6dfff62b88..23e0d2412f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27379,25 +27379,23 @@ Tramp's own encoding methods for moving data between systems.")
(license license:gpl3+)))
(define-public emacs-pcre2el
- ;; Last release is very old so we get the latest commit.
- (let ((commit "0b5b2a2c173aab3fd14aac6cf5e90ad3bf58fa7d"))
- (package
- (name "emacs-pcre2el")
- (version (git-version "1.8" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/joddie/pcre2el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "14br6ad138qx1z822wqssswqiihxiynz1k69p6mcdisr2q8yyi1z"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/joddie/pcre2el")
- (synopsis "Convert between PCRE, Emacs and rx regexp syntax")
- (description "@code{pcre2el} or @code{rxt} (RegeXp Translator or RegeXp
+ (package
+ (name "emacs-pcre2el")
+ (version "1.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/joddie/pcre2el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s6by4arny1w4i0hm4xghhjgjgb4iy7n189ddqdcsh4jrgwjyaxl"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/joddie/pcre2el")
+ (synopsis "Convert between PCRE, Emacs and rx regexp syntax")
+ (description "@code{pcre2el} or @code{rxt} (RegeXp Translator or RegeXp
Tools) is a utility for working with regular expressions in Emacs, based on a
recursive-descent parser for regexp syntax. In addition to converting (a
subset of) PCRE syntax into its Emacs equivalent, it can do the following:
@@ -27412,7 +27410,7 @@ provided the list is finite
@item provide live font-locking of regexp syntax (so far only for Elisp
buffers – other modes on the TODO list).
@end itemize\n")
- (license license:gpl3))))
+ (license license:gpl3)))
(define-public emacs-magit-todos
(package