aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-06-20 13:12:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-20 13:14:16 +0200
commit8e590c81539a79ec19bf91d3e5f8a2c4f9a659bb (patch)
treea5a17a8181f54366b393ab86f160bf3fd03ff743 /gnu/packages
parente2ab228b46a879a3147d8f40d4d98d8ebb278b6b (diff)
downloadguix-8e590c81539a79ec19bf91d3e5f8a2c4f9a659bb.tar
guix-8e590c81539a79ec19bf91d3e5f8a2c4f9a659bb.tar.gz
gnu: python2-jupyter-console: Split from python-jupyter-console.
* gnu/packages/python-xyz.scm (python2-jupyter-console): Implement without package-with-python2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2bf98222ae..d3d3ef31d0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7593,7 +7593,32 @@ Jupyter kernels such as IJulia and IRKernel.")
(license license:bsd-3)))
(define-public python2-jupyter-console
- (package-with-python2 python-jupyter-console))
+ (package
+ (name "python2-jupyter-console")
+ (version "5.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyter_console" version))
+ (sha256
+ (base32
+ "1kam1qzgwr7srhm5r6aj90di5sws4bq0jmiw15452ddamb9yspal"))))
+ (build-system python-build-system)
+ ;; Tests only run in an TTY.
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("python2-ipykernel" ,python2-ipykernel)
+ ("python2-jupyter-client" ,python2-jupyter-client)
+ ("python2-prompt-toolkit" ,python2-prompt-toolkit-1)
+ ("python2-pygments" ,python2-pygments)))
+ (native-inputs
+ `(("python2-nose" ,python2-nose)))
+ (home-page "https://jupyter.org")
+ (synopsis "Jupyter terminal console")
+ (description "This package provides a terminal-based console frontend for
+Jupyter kernels. It also allows for console-based interaction with non-Python
+Jupyter kernels such as IJulia and IRKernel.")
+ (license license:bsd-3)))
;; The python-ipython and python-jupyter-console require each other. To get
;; the functionality in both packages working, strip down the