aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:53:29 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:53:29 +0100
commit892c4cace7ae8c366e423366f5094a37486ffc59 (patch)
treeb9d5fe43f6a9fa5ee4c81f4335f8bb5392f354eb /gnu/packages
parent1434e3aeeab176d6271f912066a0b4eb18bd7759 (diff)
downloadguix-892c4cace7ae8c366e423366f5094a37486ffc59.tar
guix-892c4cace7ae8c366e423366f5094a37486ffc59.tar.gz
gnu: go-github-com-emersion-go-sasl: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-emersion-go-sasl): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I00729892042a0054b4749693f08cb36c9de72dd9
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm25
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 25 insertions, 24 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 4d9f0c0882..70397c311f 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -934,6 +934,31 @@ for Go.")
"This package provides a Go library for authenticating emails.")
(license license:expat)))
+(define-public go-github-com-emersion-go-sasl
+ (let ((commit "0b9dcfb154ac3d7515b08bc2691a0332800edfe9")
+ (revision "1"))
+ (package
+ (name "go-github-com-emersion-go-sasl")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-sasl")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cbf86wkqrdinfydndgdlnayg4a5mg3d4vqra377j2sfkg7wj0hs"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/emersion/go-sasl"))
+ (home-page "https://github.com/emersion/go-sasl")
+ (synopsis "SASL library written in Go")
+ (description
+ "This package provides a SASL library written in Go.")
+ (license license:expat))))
+
(define-public go-github-com-emicklei-go-restful
(package
(name "go-github-com-emicklei-go-restful")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4d99ca56f0..15a7954a58 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5619,30 +5619,6 @@ a cron spec parser and job runner.")
defined by RFC 5321.")
(license license:expat)))
-(define-public go-github-com-emersion-go-sasl
- (let ((commit "0b9dcfb154ac3d7515b08bc2691a0332800edfe9")
- (revision "1"))
- (package
- (name "go-github-com-emersion-go-sasl")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emersion/go-sasl")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1cbf86wkqrdinfydndgdlnayg4a5mg3d4vqra377j2sfkg7wj0hs"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/emersion/go-sasl"))
- (home-page "https://github.com/emersion/go-sasl")
- (synopsis "SASL library written in Go")
- (description "This package provides a SASL library written in Go.")
- (license license:expat))))
-
(define-public go-github-com-google-uuid
(package
(name "go-github-com-google-uuid")