aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-06-03 09:57:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-06-03 11:06:23 +0300
commit865920e01ea311a60c79dbad5322e9f7c653b3e0 (patch)
tree27368cb1b4fe71277bca0991f95ce718e3d2f429 /gnu/packages
parent2dfe45e12ed55e5f9bf3d4061200bc607e2e5db8 (diff)
downloadguix-865920e01ea311a60c79dbad5322e9f7c653b3e0.tar
guix-865920e01ea311a60c79dbad5322e9f7c653b3e0.tar.gz
gnu: spirv-llvm-translator: Skip tests on most platforms.
* gnu/packages/vulkan.scm (spirv-llvm-translator)[arguments]: Only run tests when not cross-compiling and for x86_64-linux. Change-Id: If0025060e5aa24a9d90724966887ea03f4f8c4b3
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/vulkan.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 4bcdb1b226..e46cbed4f5 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -167,7 +167,11 @@ SPIR-V, aiming to emit GLSL or MSL that looks like human-written code.")
(base32 "0yfz02mlnf4ffn67g2ms0w8f7jgdsn438w2dbxd5mvcf5dk2x27b"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags
+ ;; The test suite is known to fail on several architectures:
+ ;; https://github.com/llvm/llvm-project/issues/59637
+ `(#:tests? ,(and (not (%current-target-system))
+ (target-x86-64?))
+ #:configure-flags
(list (string-append "-DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR="
(assoc-ref %build-inputs "spirv-headers")
"/include/spirv")