aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2024-02-20 19:33:26 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-03 23:33:39 +0000
commit84266a8f74aaf3d5eac64c679ba0124de4331bfe (patch)
treea44dad3afe80a6ba5f43e1f1c4d0844e16cc6654 /gnu/packages
parent23961986cf784125cd51f6894c2e3a4e995f50a4 (diff)
downloadguix-84266a8f74aaf3d5eac64c679ba0124de4331bfe.tar
guix-84266a8f74aaf3d5eac64c679ba0124de4331bfe.tar.gz
gnu: Add debug-assert.
* gnu/packages/cpp.scm (debug-assert): New variable. Change-Id: I4cee49ea2f5b761ab72bb7b063c2ea8fd99b991c Reviewed-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Reviewed-by: Skyler Ferris <skyvine@protonmail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cpp.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 26fc169154..ed88a27e89 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -38,7 +38,7 @@
;;; Copyright © 2023 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
-;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2023-2024 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Peepo Froggings <peepofroggings@tutanota.de>
@@ -576,6 +576,29 @@ It also allows a server application to wait for any activity on any
combination of these streams.")
(license license:bsd-3)))
+(define-public debug-assert
+ (package
+ (name "debug-assert")
+ (version "1.3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/foonathan/debug_assert")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z9wfh9h83rv6khm6s6bym40vgv2igy4yh665ygsdxwamil254b9"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ; no tests
+ (home-page "https://github.com/foonathan/debug_assert")
+ (synopsis "Assertion macro for C++")
+ (description
+ "debug_assert is a C++11 header-only library which provides the
+@code{DEBUG_ASSERT()} macro, which among other features can be selectively
+enabled in different parts of your code.")
+ (license license:zlib)))
+
(define-public xsimd
(package
(name "xsimd")