aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorYann Dupont <yann.dupont@univ-nantes.fr>2024-04-18 12:20:58 +0200
committerLars-Dominik Braun <lars@6xq.net>2024-05-25 19:39:15 +0200
commit83fc6c7f72fcab3a68c82dd02f872429d632a2c0 (patch)
tree4bfaaddea74ca401603c52bf3356e5837ff9352e /gnu/packages
parentcca25a67693bb68a1884a081b415a43fad1e8641 (diff)
downloadguix-83fc6c7f72fcab3a68c82dd02f872429d632a2c0.tar
guix-83fc6c7f72fcab3a68c82dd02f872429d632a2c0.tar.gz
gnu: lvm2: Remove systemd rule.
* gnu/packages/patches/lvm2-no-systemd.patch: New file. * gnu/packages/linux.scm (lvm2)[source]: Apply patch. * gnu/local.mk: Register new patch. Signed-off-by: Lars-Dominik Braun <lars@6xq.net> Change-Id: Ib4342e0ce3cc5778857ccecd557f3d397aa870d9
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm1
-rw-r--r--gnu/packages/patches/lvm2-no-systemd.patch18
2 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a9b78a7986..67e924642e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4579,6 +4579,7 @@ one to send arbitrary keycodes when a given key is tapped or held.")
(sha256
(base32
"0z6w6bknhwh1n3qfkb5ij6x57q3wjf28lq3l8kh7rkhsplinjnjc"))
+ (patches (search-patches "lvm2-no-systemd.patch"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/patches/lvm2-no-systemd.patch b/gnu/packages/patches/lvm2-no-systemd.patch
new file mode 100644
index 0000000000..f43e568bb1
--- /dev/null
+++ b/gnu/packages/patches/lvm2-no-systemd.patch
@@ -0,0 +1,18 @@
+Fixes <https://issues.guix.gnu.org/65177>.
+
+Run 'vgchange' directly instead of attempting to run it via 'systemd-run' as
+the udev rules included in lvm2 >= 2.03.14 do.
+
+diff --git a/udev/69-dm-lvm.rules.in b/udev/69-dm-lvm.rules.in
+index ff1568145..8879a2ef9 100644
+--- a/udev/69-dm-lvm.rules.in
++++ b/udev/69-dm-lvm.rules.in
+@@ -76,7 +76,7 @@ LABEL="lvm_scan"
+ # it's better suited to appearing in the journal.
+
+ IMPORT{program}="(LVM_EXEC)/lvm pvscan --cache --listvg --checkcomplete --vgonline --autoactivation event --udevoutput --journal=output $env{DEVNAME}"
+-ENV{LVM_VG_NAME_COMPLETE}=="?*", RUN+="(SYSTEMDRUN) --no-block --property DefaultDependencies=no --unit lvm-activate-$env{LVM_VG_NAME_COMPLETE} (LVM_EXEC)/lvm vgchange -aay --autoactivation event $env{LVM_VG_NAME_COMPLETE}"
++ENV{LVM_VG_NAME_COMPLETE}=="?*", RUN+="(LVM_EXEC)/lvm vgchange -aay --autoactivation event $env{LVM_VG_NAME_COMPLETE}"
+ GOTO="lvm_end"
+
+ LABEL="lvm_end"