aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-24 23:13:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:03 +0100
commit818a854b3b42334b5172c60c5340f7be29abdb9d (patch)
tree99ec44aa15c4a05f7742379d0b36a6c6759683e9 /gnu/packages
parent7c27315ac60a9c97445b48513a9cd3ac19470798 (diff)
downloadguix-818a854b3b42334b5172c60c5340f7be29abdb9d.tar
guix-818a854b3b42334b5172c60c5340f7be29abdb9d.tar.gz
gnu: go-github-com-prometheus-client-golang: Update to 1.19.1.
* gnu/packages/golang.scm (go-github-com-prometheus-client-golang): Update to 1.19.1. [propagated-inputs]: Remove go-github-com-beorn7-perks-quantile, go-github-com-cespare-xxhash; add go-github-com-beorn7-perks, go-github-com-cespare-xxhash-v2, go-github-com-davecgh-go-spew, go-github-com-json-iterator-go, and go-golang-org-x-sys. Change-Id: I037e8a05ab572c91153badd8673ed6772474010c
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2c5f496b2e..34585a68c5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7378,7 +7378,7 @@ system, kernel, and process metrics from the @file{/proc} pseudo file system.")
(define-public go-github-com-prometheus-client-golang
(package
(name "go-github-com-prometheus-client-golang")
- (version "1.17.0")
+ (version "1.19.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7387,7 +7387,7 @@ system, kernel, and process metrics from the @file{/proc} pseudo file system.")
(file-name (git-file-name name version))
(sha256
(base32
- "1v8vdvi9wlpf18nxi62diysfnh9gc3c3cqq6hvx378snsvvl6n82"))))
+ "0mx5q221pbkx081ycf1lp8sxz513220ya8qczkkvab943cwlcarv"))))
(build-system go-build-system)
(arguments
'(#:tests? #f
@@ -7397,12 +7397,15 @@ system, kernel, and process metrics from the @file{/proc} pseudo file system.")
;; Source-only package
(delete 'build))))
(propagated-inputs
- (list go-github-com-beorn7-perks-quantile
- go-github-com-golang-protobuf
+ (list go-github-com-beorn7-perks
+ go-github-com-cespare-xxhash-v2
+ go-github-com-davecgh-go-spew
+ go-github-com-json-iterator-go
go-github-com-prometheus-client-model
go-github-com-prometheus-common
go-github-com-prometheus-procfs
- go-github-com-cespare-xxhash))
+ go-golang-org-x-sys
+ go-google-golang-org-protobuf))
(synopsis "HTTP server and client tools for Prometheus")
(description "This package @code{promhttp} provides HTTP client and
server tools for Prometheus metrics.")