aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-06 23:29:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-06 23:29:34 +0200
commit7fc41e6e6607bcf78db707d0c698d371985a6efe (patch)
tree19e7c29d7160b07aa1b006fb877482954fc6d245 /gnu/packages
parentccbd1648f461c15e79f73384ebeaccd6cdbd877b (diff)
downloadguix-7fc41e6e6607bcf78db707d0c698d371985a6efe.tar
guix-7fc41e6e6607bcf78db707d0c698d371985a6efe.tar.gz
gnu: Add emacs-poet-theme.
* gnu/packages/emacs-xyz.scm (emacs-poet-theme): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0ca1af9d05..afb55cb902 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4493,6 +4493,32 @@ variants.")
package provides a light and a dark variant.")
(license license:gpl3+)))
+(define-public emacs-poet-theme
+ (let ((commit "d84f7b259cc9b6ff8d442cf4c38bd6c7065ff8f4")
+ (revision "0"))
+ (package
+ (name "emacs-poet-theme")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kunalb/poet.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0a84jdaj619mb59a46dmkk2sfs42rylqk9ryl1drgs8d3lia79mz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/kunalb/poet/")
+ (synopsis "Emacs theme for prose")
+ (description
+ "Emacs has very good support for multiple fonts in a single file. Poet
+uses this support to make it much more convenient to write prose within Emacs,
+with particular attention paid to @code{org-mode} and @code{markdown-mode}.
+Code blocks, tables, etc are formatted in monospace text with the appropriate
+backgrounds.")
+ (license license:expat))))
+
(define-public emacs-ahungry-theme
(package
(name "emacs-ahungry-theme")