aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-12-05 10:24:37 -0600
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-10 09:13:32 +0100
commit7d48ab424b08971bb9fbf92d498865b852a02f92 (patch)
tree6acbe2633afdfd8a6116e5bed7b0c2bec5678e1a /gnu/packages
parentd0a038b17a99e0ba25703e44177988d0a1ab1cc6 (diff)
downloadguix-7d48ab424b08971bb9fbf92d498865b852a02f92.tar
guix-7d48ab424b08971bb9fbf92d498865b852a02f92.tar.gz
gnu: Add emacs-acme-theme.
* gnu/packages/emacs-xyz.scm (emacs-acme-theme): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index aafa7240fd..a3c6c404b5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1351,6 +1351,29 @@ this one is much simpler and much more consistent. When using this package,
then only the color of the mode line changes when a window becomes in-/active.")
(license license:gpl3+)))
+(define-public emacs-acme-theme
+ (let ((commit "7c408d111c5e451ecb8fdd5f76cf7d8074aec793")
+ (revision "0"))
+ (package
+ (name "emacs-acme-theme")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/ianyepan/acme-emacs-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16qxspzlf0bvw36ff4qnrn5p7mc5sf923ba0ar04cr87bfqgyak4"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ianyepan/acme-emacs-theme")
+ (synopsis "Emacs theme inspired by Plan 9's Acme and Sam Editor")
+ (description "Acme theme is an Emacs theme with an old-school vibe
+inspired by Plan 9 Acme and the Sam text editor.")
+ (license license:gpl3+))))
+
(define-public emacs-theme-magic
;; No tagged release upstream, but the commit below correspond to the 0.2.3
;; release.