aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:30:55 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:36:58 +0100
commit7a8126e107999b2af4a50bd2ff7e8f1a9faaedab (patch)
tree275055a2accd7b72d3404d0a0223c1a94aff7f22 /gnu/packages
parente2f5651c15d0b94ea896bbff8e96f039f3ab34e5 (diff)
downloadguix-7a8126e107999b2af4a50bd2ff7e8f1a9faaedab.tar
guix-7a8126e107999b2af4a50bd2ff7e8f1a9faaedab.tar.gz
gnu: go-github-com-emersion-go-maildir: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-emersion-go-maildir): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I75029fd66f94a807d87e877df7fc962f3ee567e1
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm23
-rw-r--r--gnu/packages/golang.scm23
2 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index d0a324e909..3c196ef228 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -799,6 +799,29 @@ used to build IMAP clients and servers.")
@code{go-github-com-emersion-go-imap}.")
(license license:expat)))
+(define-public go-github-com-emersion-go-maildir
+ (package
+ (name "go-github-com-emersion-go-maildir")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-maildir")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wa7spn3qa7ipmg29vrimw7phyybyaagdalrjklcazjb6rplvwpl"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/emersion/go-maildir"))
+ (home-page "https://github.com/emersion/go-maildir")
+ (synopsis "Maildir interface for Go")
+ (description
+ "This package provides an interface to mailboxes in the Maildir format.")
+ (license license:expat)))
+
(define-public go-github-com-emersion-go-message
(package
(name "go-github-com-emersion-go-message")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f90b28691b..5668ff25bc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5643,29 +5643,6 @@ defined by RFC 5321.")
(description "This package provides a SASL library written in Go.")
(license license:expat))))
-(define-public go-github-com-emersion-go-maildir
- (package
- (name "go-github-com-emersion-go-maildir")
- (version "0.5.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emersion/go-maildir")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0wa7spn3qa7ipmg29vrimw7phyybyaagdalrjklcazjb6rplvwpl"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/emersion/go-maildir"))
- (home-page "https://github.com/emersion/go-maildir")
- (synopsis "Maildir interface for Go")
- (description
- "This package provides an interface to mailboxes in the Maildir
-format.")
- (license license:expat)))
-
(define-public go-github-com-emersion-go-milter
(package
(name "go-github-com-emersion-go-milter")